The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Sections/Elevation/3D Document/Worksheets/Details etc., Annotations, Texts, Labeling, Autotext/Project Info, Layouting, Renovation Filters, Graphic Overrides, Revisions/Issues, Printing/Plotting, PDF, Mark-Up, etc.

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

By Chris Hinrichs
#308209
Hi All. I'm looking for help with an issue we're having. We model all our walls using complex profiles, with the stud space being the core and things like gyp. board, sheathing, and siding as finishes or other. On our floor plans, walls show "core only" and are dimensioned as such. However, if we are working in plan and then go to a 3D view and, say, rotate it, then go back to the plan view, the dimensions "jump" and now reference other parts of the profile that aren't cores. The fix is easy. We can select all the dimensions (one story at a time) and go into the selection settings and just hit OK and the dimensions go back to where they belong. However, if we forget to do this, we could pontentially send out drawings with incorrect dimensions. Has anyone encountered this? I have communicated with tech support and they have not had a solution. In my opinion, dimensions should never change without the user telling them to. I also checked projects done in AC22 and this problem doesn't occur. This glitch is huge for us and could lead to big problems in the field if we don't catch it. Converting all out walls to composites is just not an option. Any suggestions would be appreciated!
Attachments
After.JPG
Before.JPG
Wall Profile.JPG
User avatar
By Barry Kelly
#308225
Is your signature correct - AC15?
Or is it just old?

What version are you experiencing the problem in?

I don't have a solution but I am wondering if the plan is not showing the finishes and the 3D document is?
I know that in plan you have to add dimensions to each partial structure display.
I am wondering if somehow it is switching because the finishes were shown in 3D? (long shot).

Or if you are using 23, there are new settings in the way dimensions are done.
What settings do you have?

dimension_settings_2.jpg
dimension_settings_2.jpg (7.79 KiB) Viewed 864 times

Barry.
User avatar
By Barry Kelly
#308230
Chris Hinrichs wrote:
Wed Mar 11, 2020 4:00 pm
The fix is easy. We can select all the dimensions (one story at a time) and go into the selection settings and just hit OK and the dimensions go back to where they belong.

Just wondering if a Rebuild & Regenerate would work (CTRL+ALT+SHIFT+R).
Probably not but it is worth a try.

Barry.
#308325
Hi Barry. Sorry. I have not posted in this forum in a long time (apparently since I was using AC15!)

The plan is not showing finishes or other. Core only. To be clear, the glitch occurs when I go from the plan to the 3D viewport, not a 3D Doc, alter it slightly (rotate the model, move something, etc.), and then go back to the plan view. I will check to see that my settings are correct and hope that is causing this, although it seems tech support would have caught something this simple before they sent it up to tier two for investigation. Thanks and I'll keep my fingers crossed! This is driving me nuts!
User avatar
By mnguyen
#308378
Hi Chris,

Thank you for sharing the issue and I am very sorry about the experience!

I checked our database and found your case recorded in our system. The screenshots were very similar, but the description from the case was slightly different.

It was mentioned that the dimension "jumped" to the incorrect position (from core reference points to finish reference points) when changing the wall type from Profile to another profile or Composite.

This was tested in ARCHICAD 23 and previous versions as well. What we found out was, this is a limitation of ARCHICAD. The dimensionable spots of a Profiled wall cannot be 1-1 matched with that of Composite wall, so there is no same way to retain logical dimensionable points. We are still working on how to improve this behavior.

I personally tested the issue myself (on both AC22 and AC23), however, even by selecting all the dimensions, open their Settings and click OK, it did not fix the wrong dimension spot.

Image

What you mentioned here was different from what was investigated in our system. Unfortunately, I cannot replicate this issue. I'm wondering if you could make a small video recording how to reproduce this?

Thank you very much for your help, and I look forward to hearing from you!

Best regards,
Minh
#308386
Again, it has nothing to do with changing from complex profile to composite. As you can see in the GIF file (too big to upload, link below) the dimensions start out in the proper location, as I entered them. Then I go to the 3D viewport and rotate the model a little. Then I go back to the floor plan and the dimensions have jumped to where the finishes would be if they were turned on. Then I use Find/Select to select all the dimensions, open the selection settings and do nothing other than hit OK. Then the dimensions jump back to the correct location. This is a huge impediment to our workflow and output in the case that we don't remember to "fix" the dimensions (one story at a time) before printing or saving to PDF. I am unable to replicate this same glitch in AC22 using the same file. Thank you for your help. If you still don't understand the issue, perhaps we can schedule a phone call. I really need to get this resolved!

https://drive.google.com/file/d/1C-Ok6f ... sp=sharing
User avatar
By mnguyen
#308387
Hi Chris,

I believe you’re using AC23 USA on Windows 10? Anyhow, thanks to the GIF, I managed to reproduce this on INT version as well.

After testing the file, I found out that, the floor plan view seems to inherit the Partial Structure Display from 3D view after switching from 3D to floor plan. To be honest, I can't figure out a simple way to fix this issue (however, doing Rebuild & Regenerate twice will move the dimensions back to the correct position, so you won't have to check each story one by one).

I'm wondering how did you create the dimension? By manually draw them one by one, or by using Automatic Dimensions?

I will forward this to the developers to see if it is possible to fix the dimensions in this file. Thank you very much for your help!

Best regards.
Minh
#308391
Thanks, Minh. I typically draw my dimensions manually just because when I use automatic dimensioning I end up having to move a bunch of them around anyway. I use AC23 and Windows 10. I hope you can figure out a fix. The fact that this doesn't occur in AC22 gives me hope!
User avatar
By Barry Kelly
#308395
Chris Hinrichs wrote:
Sat Mar 14, 2020 8:05 pm
Hi Barry. Sorry. I have not posted in this forum in a long time (apparently since I was using AC15!)

To be clear, the glitch occurs when I go from the plan to the 3D viewport, not a 3D Doc, alter it slightly (rotate the model, move something, etc.), and then go back to the plan view.

Yes sorry, when I said 3D document, I meant 3D view.
As Minh discovered as well, your plan is 'core only' but the 3D is 'entire model'.
When you go back to plan it for some reason the dimensions now show to the extent of the finishes.

They shouldn't of course and this is odd because each Partial Structure Display actually has it's own dimensions, so the finish dimensions shouldn't be showing at all on the core only display.

I am wondering if just switching to 'entire model' and then back to 'core only' in the plan view will be enough to reset the dimensions back to where they should be.

Otherwise switch the plan to 'entire model' before going to 3D and then switch it back to 'core' only when you return to plan view (of course this should not be necessary).

Or open a 3D view that is also 'core only' so the PSD is not changing (again this should not be necessary but may offer a work around).

Barry.
#308412
Hey Barry. To answer your question, yes, I can correct the dimensions by going to entire model and then back to core only. That's probably the quickest solution for fixing them. Still, I feel like when I put a dimension in, it should always reference the points I wanted it to and only change if I move the model element I'm dimensioning. I have a million things to remember when I'm creating a set of construction docs. I don't want to have to remember to check whether the dimensions I entered have moved. We sent out a set of drawing once with incorrect dimensions which caused a bunch of problems in the field and made us look really bad. Anyway, I appreciate your help!