The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Import/Export to other CAD/BIM formats (DWG/DXF, IFC, SketchUp, 3DS etc.), spreadsheets, databases etc.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy

By SFarris
#273015
I'm using the student version of Archicad 21 and Rhino 5. When I first downloaded Archicad, I had absolutely no problem importing .3dm files. Later I also tried the Archicad-Grasshopper-Rhino connection and it seemed to be working properly.

Recently, when I've tried importing 3dm files (either through File > Open or File > Interoperability > Merge), it either says there is invalid geometry or it tries to load the objects before crashing and sending an error report. I've tried cleaning and repairing the file in rhino first, but even if it doesn't warn me about invalid objects, it still inevitably crashes. I've tried it with small and large files. So far the only file I've been able to import was a rhino test file with literally one box, so it would seem like it's a problem with the rhino files themselves, but I had no problem importing many of the exact same files before this started.

Since this only started after installing the Grasshopper connection, I uninstalled that. I also reinstalled my version of Archicad 21. No luck. And I can't find mention of this problem or the error codes anywhere.

What am I doing wrong?