The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, Gordana Radonic, nbalogh, gkmethy, mnguyen

By ksjhawk
#325549
We have a mac mini running 10.12.6 that is our keyserver. It houses our physical key for 19 net keys. Every 4-6 weeks, the codemeter software service stops running. No amount of restarting the codemeter app restores this and everyone is disconnected until I restart the machine.

Has anyone else experienced this? Going forward, I'll schedule the machine to restart every couple of weeks, but the machine is in the office and we are still remote so if it doesnt start back up, we have to wait for someone to go in and restart it.

Anyone used a virtual machine for a keyserver by chance?

Thanks in advance.
#325557
I am pretty sure you can't use virtual machines to run licenses.
Otherwise you would be able to create multiple virtual machines - therefore multiplying your licenses.

I don't run Macs at all, but have no trouble with physical network keys on remote servers, running 24/7.
Is it because you Mac machine is doing a system update? - Macs always seem to be updating to me - seems like a new or updated OS every couple of months.
Can it be set to manual updates so you can control it when someone is in the office?
I have no idea if that is the cause, but would be something I would try.

Barry.
#325581
Barry Kelly wrote: Thu May 06, 2021 1:35 am I am pretty sure you can't use virtual machines to run licenses.
Otherwise you would be able to create multiple virtual machines - therefore multiplying your licenses.
I don't think this is the case, Barry - as a device can only be connected to a single running virtual machine at one time. ksjhawk's licenses are on a Codemeter key... and such a USB device can only be connected to one running VM.

ksjhawk: I assume that 10.12.6 is the most recent version of MacOS that your mini can run? If so, then restarting on a regular schedule might be the easiest solution other than a VM. The only suggestions I would have made otherwise would be to examine the console logs to see if anything amiss is reported about the Codemeter...and or regularly run Onyx to clean up system caches/etc... but Onyx requires a reboot... so if simply rebooting solves the issue, might as well stick with that. (You can schedule a reboot/restart via Terminal so that it happens every Sunday morning at 0300 or something like that.)
User avatar
By mikas
#325603
We have been serving 5 licenses from Macs for years allready, and lately exclusively from Mac Minis. Mostly without a trouble. First one was a Mac Mini 2009, eventually running El Capitan. It was also a file server, but was still very reliable. Uptime might have been over a year with El Capitan, and several months with Mojave. Mostly it's some OS security update which needs a restart.

Now we have upgraded to a Mac Mini 2012 with Mojave. Mostly trouble free if it's let alone, just serving the licenses, and some older files in there too as back-ups.

No special software installed, and no remote usage allowed. That's because it happened once that it ran out of memory and stalled. I tracked that to remote usage process, it had swallowed all the installed memory (almost 16GB). A memory leak I think, which accumulated the RAM problem in few months time.

Another stall happened when someone accidentally left a mouse on the keyboard, and that way the keys there then being pressed continuously. Eventually it crashed the machine.

None of that helps you obviously, I'll get to the point:

1) You could try upgrading from Sierra to High Sierra. If I remember it right, if Sierra is supported, your Mac is upgradable to High Sierra too. In my opinion plain Sierra was not so great of an OS. If this works, it was the OS + codemeter combo.

2) You might want to check your codemeter software and maybe download the newest driver from Wibu systems. You can go back to original if it doesn't help. If this works, it was the OS + codemeter combo.

3) It seems your Mac did not crash, and you were able to use it still, just the licenses where lost? Allthough improbable, that does not necessarily shut away a possibility of some hardware problem. Maybe try another Mac, just clone the server OS HDD/SSD with CCC to an external drive, and start from the external drive with another Mac. Use as a server for a while. If it works, it was something hardware related.

It's a pain to troubleshoot, and you would of course want to avoid any longer than necessary downtime, as we all would. That's why I put a list in my opinion most appropriately ordered to try track it down.

Good Luck.
By ksjhawk
#325628
Thanks all. Good feedback and good ideas. We have moved forward with a scheduled restart and will discuss updates vs. upgrade with our IT consultant. I know enough to be dangerous but prefer my architect job over my IT job, most of the time. And correct Mikas, the machine did not crash, just the codemeter software. Hoping some combination of restart schedule and updates will keep us on line longer w/o interruption.

Thanks again and will let you know how things go.