The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, Gordana Radonic, nbalogh, gkmethy, mnguyen

#325325
Hi There!

Same problem showed up with AC24 now (stairs not apperain on layout despite correct view/layer settings). Unforunately none of the above mentioned solutions work, including changing renovation status of the stairs.

Any suggestions how to fix it? For now, my only solution is to redraw the stairs with lines and hatches to appear on the layout....

Any feedback appriciated.
#325407
archehade wrote: Fri Apr 30, 2021 7:27 am Hi There!

Same problem showed up with AC24 now (stairs not apperain on layout despite correct view/layer settings). Unforunately none of the above mentioned solutions work, including changing renovation status of the stairs.

Any suggestions how to fix it? For now, my only solution is to redraw the stairs with lines and hatches to appear on the layout....

Any feedback appriciated.
Hello,

Thank you very much for the report and I am very sorry about the experience!

If the above suggestions don't help, I'm wondering if it's possible for you to share with me the file for further investigation? Please let me know if you need a secure place to upload the file also!

Best regards,
Minh
#326113
Dear all,

Just want to give you a quick update: fortunately, the workaround also worked in Rahim's case. Unfortunately, we still don't know how the stairs got into this corrupted state yet, so the case still remains open. Please let me know if you happen to find out how to create the corrupted stair!

Best regards,
Minh
#328097
Hello,

I'm having the same problem with the stair steps not showing on the layout, the stringers are still visible though. In my case it is related to spiral stairs, straight stairs are fully visible. It's not related to the view settings (I right click the faulty view on the layout and select "open source view" and the stairs are fully visible then)

I have tried everything, changing the renovation status of the stairs in different orders (change status to demolish-change status back to existing-update view on layout / change status-update view on layout-change status back-update view on layout / change status from existing to new-update view / etc).

I've tried to reset the renovation status of everything in the model. I've tried to use the pipette to redraw the buggy stair as a straight stair to no effect. I've checked some stair copies that I had saved in the dummy layer that I havent edited since the stair type last was functioning properly but those also are missing their steps.

I'm using AC23 v5005 SWE FULL

Any thoughts or more specific instructions to apply the workaround?

Thanks in advance

Edit:
I've tried changing the finish type from Step (built in) to Step 23, which I use in my straight stairs but that didn't change its representation on the layout view. I tried to change the structure from stringers (which are visible) to monolithic but then the entire stair disappears in the layout.

Edit2:
It's only the stringers that remain visible, the walking line is missing as well. I'm not sure about the numberings as they should not be visible as per the MVO.
Last edited by Agrell on Thu Jun 10, 2021 7:48 am, edited 1 time in total.
#328099
Just a hunch, but open the stair in EDIT mode.
Then select each component and check the renovation status.
You may need to do the 'change it to something else and then change it back' trick if it is already set tot he correct reno filter.

It is possible to have the entire stair as 'Exiting' but the individual treads can be 'New'.

Barry
#328101
Good suggestion, unfortunately it did not help. I tried changing the individual steps renovation status (but they did not disappear from my 3D-view when set to a non visible ren.stat?) and changing them back again. I changed/changed back the status of the plan symbol and walking line symbol as well when in "edit mode", to no effect. I tried changing the plan symbol from the one called "build in" to the one called "23" but that did not help either. Same for the walking line.

I´ve tried creating a new layout and placing a new view on it, but the result remains faulty.
#328103
Hello,

Thank you very much for the report and I am very sorry to hear that!

Instead of changing the Renovation status, have you tried changing the Show on Renovation Filter option instead?

Image

Simply change this option to another Renovation Filter, then change it back to All Renovation Filter will also solve the issue in some cases.

Please let me know if it works!

Best regards,
Minh
#328104
Hi,

That actually solved the problem! Thank you very much!

I actually noticed that the renovation filter options were strange when looking at the individual components while in "edit stair mode" previously. They were not on the all relevant filter-setting, they were set to only be shown in the existing filter (I have not been messing with the filter options previously in this project so it wasn't me using these settings). So I changed them back while in edit stair-mode but that did not solve the problem. I also reset the projects filter options to all relevant filters in the reset renovation status dialogue box, but that did not help either.

But your suggestion to change show on renovation filter for the entire stair object solved my problem. I cannot emphasise how grateful I am right now. Thanks again!

Best regards