The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Modeling and drafting in Archicad. (Example: How can I model a Roof soffit/fascia?)

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, Gordana Radonic, nbalogh, gkmethy, mnguyen

User avatar
By Vojtech Slavik
#328439
Does anyone know why this happening ?

Where it became this 1 millimetre from 32000mm ? :(

Can I lock measures for be precise for Integer number ?
Attachments
Skärmavbild 2021-06-17 kl. 13.41.08.jpg
Skärmavbild 2021-06-17 kl. 13.41.08.jpg (55.41 KiB) Viewed 206 times
IMG_1972.jpg
IMG_1972.jpg (470.76 KiB) Viewed 206 times
IMG_1973.jpg
IMG_1973.jpg (463.31 KiB) Viewed 206 times
IMG_1974.jpg
IMG_1974.jpg (400.38 KiB) Viewed 206 times
User avatar
By Braza
#328452
AC has maximum 4 decimals after the comma. Sometimes I copy/paste dimension from a calculator. If the pasted dimension has more then 4 decimals, then AC will display only 4. But the rest of the dimension is stored in the parameter and you won't see it. Then with cumulative dimensions it will appear like your situation. Try to reenter the exact dimensions and see if the problem persist.
Hope this helps.
User avatar
By Vojtech Slavik
#328456
I understand but Why is this exist if I can see it or who is need in Architecture 0,001 mm ? :roll:

This was example and I did whole building and the end I got this 1mm from somewhere, also the snapping on 89,99 make me crazy :-/

Isn't any way how to lock for integer ? I wanna trust Archicad for helping me with guide lines and not writing every dimension :-/

Thank you
Braza wrote: Thu Jun 17, 2021 4:04 pm AC has maximum 4 decimals after the comma. Sometimes I copy/paste dimension from a calculator. If the pasted dimension has more then 4 decimals, then AC will display only 4. But the rest of the dimension is stored in the parameter and you won't see it. Then with cumulative dimensions it will appear like your situation. Try to reenter the exact dimensions and see if the problem persist.
Hope this helps.
User avatar
By Braza
#328459
You can set your dimension preferences in Options > Project Preferences > Dimensions.
You can find more information here: https://helpcenter.graphisoft.com/user-guide/89377/
You also can set snapp guides here: https://help.graphisoft.com/AC/24/INT/_ ... ion-51.htm
But you have to be careful when you copy/paste dimension values.
Hope this helps.
By DGSketcher
#328472
A cautionary tale on rounding. If you are displaying integer values and you have two lengths of 10.4mm, then those dimensions will round down to 10mm, but if you dimension end to end that will be 20.8mm and the displayed value will be 21mm. This isn't an Archicad specific issue, it is common to all CAD systems. The best solution is to work from the extents before measuring to the subdivision and be accurate with your length AND orientation. AC seem to be quite good at suggesting guide lines which are just off orthogonal these days.

Personally I have two dimension settings, one which shows maximum accuracy to highlight any sub integer errors when modelling and another only show integer values which is the one used with my view settings.
User avatar
By Vojtech Slavik
#328493
But can I see in Tracker 0,001 value ? Right now I can se just integer.


The rounding is true how you say.

My workflow is like do one wall with length ( 5000) and the other wall is following to the first wall and I expecting to have the same measure 5000.

If I did mistake and the first wall was 5000,8=> 5001 I get the another wall also 5001. It's much easer to fix this issue than have one of the walls 5000 and other 5001 ( because you don't know with one is wrong.


Anyway thanks for advices :-)

I have to read it again and try to little bit more understand Guidlines
Attachments
Skärmavbild 2021-06-18 kl. 08.49.44.jpg
Skärmavbild 2021-06-18 kl. 08.49.44.jpg (21.35 KiB) Viewed 149 times
User avatar
By Vojtech Slavik
#328494
I still don't get it, where is the 1mm from 32 00(1) :evil:
Attachments
Skärmavbild 2021-06-18 kl. 09.14.05.jpg
Skärmavbild 2021-06-18 kl. 09.14.05.jpg (57.76 KiB) Viewed 147 times
Skärmavbild 2021-06-18 kl. 09.13.59.jpg
Skärmavbild 2021-06-18 kl. 09.13.59.jpg (59.86 KiB) Viewed 147 times
User avatar
By Braza
#328504
Well... The image proves that the dimensions and rounds are correct. (Only higher than 0.5mm adds 1mm to the dimension). The problem is in the input. Again: You have to precisely enter all your dimensions.
User avatar
By Barry Kelly
#328505
20000.4 will round to 20000
12000.4 will round to 12000

But end to end they will measure 32000.8 which will round to 32001

You can show extra accuracy in your dimension preferences and you can also increase the accuracy of the working unit preferences, so you will see more precision in the tracker.

Barry.
User avatar
By Vojtech Slavik
#328507
Nice you are right I have exactly 20000.4 and 12000,4 ( How did you know that is this number :o )
And I can see decimals finally "working unit preferences"

Nice thank you

Barry Kelly wrote: Fri Jun 18, 2021 10:02 am 20000.4 will round to 20000
12000.4 will round to 12000

But end to end they will measure 32000.8 which will round to 32001

You can show extra accuracy in your dimension preferences and you can also increase the accuracy of the working unit preferences, so you will see more precision in the tracker.

Barry.