The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

By JennB
#176198
Trying to use spell check in ArchiCAD 13 and 14 and cannot get it to work. It keeps giving me a error message saying 'cannot initialize MS Word'...
How do I fix this?

Thanks in advance!
User avatar
By MMontgomery
#176205
There are a few threads on this if you do a search of the forums.

There are several problems with ArchiCADs spell checker, but one thing to start with is your spell check settings in MS Word (yeah, ArchiCAD uses the settings defined in the actual Word app) and make sure that it is set to check words in all Uppercase, by default that is turned off.
By JennB
#176275
MMontgomery wrote:There are a few threads on this if you do a search of the forums.

There are several problems with ArchiCADs spell checker, but one thing to start with is your spell check settings in MS Word (yeah, ArchiCAD uses the settings defined in the actual Word app) and make sure that it is set to check words in all Uppercase, by default that is turned off.
I changed my preferences in Word... It was set to ignore words in uppercase but I am still having the same problem.... And I search the forum but no problem was like this.... at least from what I read. So frustrating!!
User avatar
By MMontgomery
#176289
I believe the 'Cannot Initialize MSWord' is a known issue.

I get that error when it runs across the '@' which we use rather extensively (MTL. STUDS @ 16" O.C. etc...)
By denmarch
#196008
javascript:emoticon(':x') Spell check is a basic function. Why are some basic functions in Archicad not fixed!!! I second the frustration!
By JennB
#204185
I am now having issues just starting spell check in ArchiCAD 15 and it gives me the 'cannot initialize MS Word' message and ArchiCAD crashes...
I have checked my settings in MS Word and I don't notice anything wrong.
I'm not the greatest speller in the world so this tool is very important!
By dabarch
#206608
I have installed AC16. I was hoping that Spell Checker would work. NOT. I didn't have problems with Spell Checker until I installed Office 2010 last year. I would like this tool to work. Does anyone have any ideas? Thank you.
User avatar
By Katalin Takacs
#206772
Dear dabarch,

If your Microsoft Office language settings are set properly (as it is described here: http://archicadwiki.com/Bugs/SpellCheck ... Initialize), but you still get the "Cannot initialize MSWord!" warning message in ArchiCAD 16, please contact your local distributor. We are going to investigate the source of your problem.
By dabarch
#206784
This is what I posted in September 2011: "I was having no problems with Spell Checker up until I installed Office 2010. I thought it was a problem with AC15 but come to find out AC14 Spell Checker doesn't work now either? I have seen the link to set up the options within MS Word but that is for 2007 Word. However, I have made the similar changes within Word 2010 and it doesn't help. AC Support thinks I should get in touch with "Microsoft regarding the issue"--why would MS care if Spell Checker works in ArchiCAD? Is anyone else having a similar problem? Your help would be very much appreciated. I can't spell worth a beans so I need all the help I can get."

Update: Spell Checker does not work on my desktop computer with AC 16, 15, 14... As I indicated above after I installed MS Office 2010--MS Word 2010--Spell Checker would no longer work? However, I just got a new laptop computer and it has MS Office 2010--MS Word 2010--and Spell Checker does work on the AC files that don't work on my desktop computer? Difference: MS Office 2010 was installed over MS Office 2007. Is there somehow a conflict between the two. My spell checker in MS Word/Excel works fine, etc. I wonder if there is a conflict between ArchiCAD and Word 2007 and Word 2010 in the registry?

I have not used Spell Checker for over a year. I sure would like to use it again. Any help would be appreciated. :(