The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

By Takis
#253414
Hi I work with Archicad 19 and I have a problem with keyboard shortcuts which occurs when I forget to switch my keyboard Language to English.

So if I press Ctrl+Shift+D to drag a copy while the active language is "Greek" is not working.

Switching back to English Language keyboard shortcuts are not working and needs an Archicad restart to make it working again.

MacPro Late 2013
Apple keyboard
Windows 10 x64
User avatar
By LaszloNagy
#253442
Do you really actually use two keyboard layouts? I means, switch to one in some programs, switch to the other in others?
I have a HUngarian keyboard on my laptop so after a while I figured: why do I have an English keyboard layout installed when my keyboard is Hungarian? It just adds confusion. The only reason it was there (the English) is because I have an English version of Windows and it installs it by default. So I just uninstalled the English, left the Hungarian and there is no issues coming from keyboard layout switching.
Something to consider if this matches your situation.
By Takis
#253446
Hi, yes I have two languages installed because the most of my programs work in English and I have to write in Greek also.

For example in Archicad I use english for the kyeboard shortcuts but when I work on a project the text of the project notes has to be in Greek language.

Nevertheless I believe that this shouldn't affect Archicad's shortcuts.
By grand106
#253724
I am facing the same problem.but it doesn't appear everytime i switch from greek to english but after a little while or maybe more. I have A18 English version and surely i want to be able to write text in greek . While returning keyboard into english lets me use the wasd keys for flying mode, the shortcuts like ctrl+t and all the others dont work (even the simple ones like pressing m for measuring a distance.
The strange thing is that it is not happening after i toggle from english to greek and back once or twice so i am not even sure if its related to the second keyboard layout we have
Maybe Takis have you found a solution?
By Takis
#253733
Hi, yes the solution that I use and works is to reload your profile:

Options --> Work Environment --> choose your profile and click apply.

The above procedure works only for this kind of problem i.e keyboard shortcuts are not responding.

Takis
By grand106
#254142
Sir Takis huge respect :D :D
i was a little late to respond to your fast reply cause i havent actually made a custom profile for myself (i wasnt sure what and where to reload) so i only had to reload the standard profile .
and yes everything worked as normal (shortcuts ad stuff)
:!:
By grand106
#254700
the complete solution -works perfectly- as a member of archicad technical support team gave it to me :
Apparently by default AC shortcuts are set up to take the characters into account instead of the keyboards button when you press a shortcut combo.
And because of this when you use the GRE input language, you press Ctrl+Shift+delta, instead of Ctrl+Shift+D and that is why the "Drag a copy" does not work.

The good news is that you can change this setting in the registry keys.
- Open "Regedit" in the Windows start menu
- Navigate to HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 19.0.0 INT R1\KeyMode Shortcuts registry key and change the value of it from 0 to 1

Now AC will take the keyboard button pressed down disregarding the actual input character.
User avatar
By bari-hallaq
#296942
grand106 wrote:
The good news is that you can change this setting in the registry keys.
- Open "Regedit" in the Windows start menu
- Navigate to HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 19.0.0 INT R1\KeyMode Shortcuts registry key and change the value of it from 0 to 1

Now AC will take the keyboard button pressed down disregarding the actual input character.
that worked perfectly for me, Thanks a lot