The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

User avatar
By anto_bg
#265523
The following bug shows up repeatedly with any version of ArchiCAD. No matter how many times I re-start the program, sometimes the keyboard shortcuts do not function. In this particular case, I have been trying to drag the element by pressing CTRL + D and then CTRL again to copy it but the CUT option appears any time I press the CTRL key. Please let me know I can fix this issue. Thank you!
User avatar
By David Collins
#265536
Switching keyboard languages from English to Cryllic will kill the shortcuts.
I've also recently had this problem from time to time when I switch the keyboard language from English to Greek and then back to English. I think its a Windows 10 issue. I haven't figured out how to fix that yet.
User avatar
By anto_bg
#265732
Thank you both for your suggestions!
I think the root of the problem are the keyboard languages. I was switching constantly between English and Cyrillic. It's an ongoing issue. It used to happen with the older versions of Windows as well.
By grand106
#266914
- Open "Regedit" in the Windows start menu
- Navigate to HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 19.0.0 INT R1\KeyMode Shortcuts registry key and change the value of it from 0 to 1

Now AC will take the keyboard button pressed down disregarding the actual input character.
By mimoutis
#298351
Hello my friends. I have the same problem but unfortunately in the archicad 21 registry i cannot find the specific KeyMode Shortcuts registry key. any ideas?
User avatar
By LaszloNagy
#298422
It is there in my AC21 INT version, as you can see it in the screenshot.
If it is not there for you, you can try to create it. You will have to right-click on the right side, and use the "New > DWORD (32-bit) Value" command to create the value and give it the name "KeyMode Shortcuts".
I think after doing this an quitting the Registry Editor, you will have to restart ARCHICAD.
Attachments
AC21-Registry.png