The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

#271935
Is anyone else finding that on a 4K screen, following the recent Windows 10 Creators update, that the ArchiCAD mouse pointer is now insanely small? (for all ArchiCAD versions)

ArchiCAD is the only application so affected, and while increasing windows UI scaling, and increasing windows mouse pointer size to maximum within Windows Control Panel generallyworks as expected for everything else, the mouse pointer once moved over the ArchiCAD application window) becomes so tiny it is barely visible - and certainly the ArchiCAD dynamic pointer style context feedback is utterly undetectable.

This seems to stem from ArchiCAD's non compliant method of handling the custom mouse pointer DPI scaling rather than anything with the OS - as is demonstrated by nearly ALL other applications that predate the windows update being unaffected. (perhaps a compromise or carry over from the way custom mouse feedback is implemented for the Mac platform?)

Rolling back to or reinstalling an earlier version of Windows 10 are not good options in my case.

What have others done to solve this serious problem?
#271995
Paul King wrote:Is anyone else finding that on a 4K screen, following the recent Windows 10 Creators update, that the ArchiCAD mouse pointer is now insanely small? (for all ArchiCAD versions)
Yep, same problem here.
#272003
Do you have the latest AC21 update, build 4004, installed?
In the list of fixes I read this:
230368 USER INTERFACE: For Ultra High Definition (4K) screens, mouse cursor appeared small inside ARCHICAD in Windows 10 with Display Scaling enabled.
http://www.graphisoft.com/downloads/arc ... Notes.html
http://www.graphisoft.com/downloads/arc ... .html#4004
#272005
Thanks Lazlo - that update looks hopeful. Not yet tested or released for New Zealand I see.
I would update with the preview version now anyway (a great idea making these available!), but have BIMserver & other users to consider.

In the meantime, is there a way that Windows 10 can actually have display scaling disabled? (since as described that appears to be a requirement for the bug to manifest)

I have not found a setting that makes any difference in Windows control panel or via application compatibility settings
Ticking the 'disable display scaling on high DPI settings' option in ArchiCAD properties/compatibility settings menu does nothing for example.
#272049
Just tested the 4004 update, and sadly no immediate improvement at all to issue "230368 USER INTERFACE: For Ultra High Definition (4K) screens, mouse cursor appeared small inside ARCHICAD in Windows 10 with Display Scaling enabled."

However the update does now allow windows application compatibility settings for DPI scaling to work for ArchiCAD 21 (previously they made no difference)

After patching ArchiCAD, AND toggling DPI scaling compatibility settings to 'on' then 'off' again, seems to clear the mouse pointer scaling issue

Process is: Right click the ArchiCAD 21 icon to access properties/compatibility settings, then tick to 'Override High DPI scaling behaviour' for all users, then apply. Restart PC (not 100% sure this step is required, but is what I did), then go back , right click icon again and revert compatibility settings for all users back to the default

Mouse pointer is then back to normal size.
#272051
Not helpful for the size, but if you find you keep losing the cursor, you can enable rulers, right click in them and choose cursor projection. You get cross hairs on your screen.

A bit of a hidden feature, so thought I'd mention it.

Would be nice if this gets fixed for whenever we do upgrade from HD screens to 4K, though.
#272053
Erwin Edel wrote:Not helpful for the size, but if you find you keep losing the cursor, you can enable rulers, right click in them and choose cursor projection. You get cross hairs on your screen.

A bit of a hidden feature, so thought I'd mention it.

Would be nice if this gets fixed for whenever we do upgrade from HD screens to 4K, though.
Thanks Erwin. After patching with preview 4004 update I discovered the problem can now be solved by also toggling DPI scaling compatibility settings on then off again as above - but ruler trick will help people waiting for the official release
#272103
Doesn't help with seeing the actual cursor icon any clearer I would assume though, but at least it is very obvious where it is :lol:

The broken work around toggle thing at least gives hope for a future fix!
#272147
OK, looks like the tiny mouse pointer bug is definitely not fixed - every time I reboot the PC, the problem is back.

You can clear it with the compatibility toggling procedure I outlined above, but users should not be forced to jump through these hoops every time the boot up their computer
#272263
Hello everyone,

We have just released the final version of the first update of ARCHICAD 21. The preview update (4004) had part of the solution for this problem, but the final version (4022) has the full solution, so make sure you have that installed!

In most cases installing the update should solve the issue, but sometimes (like in case of Paul King) this fix won't change a thing. In these cases you will have to manually set the cursor size from the Registry. You can find a full description of this issue and the solution in this Article:
http://helpcenter.graphisoft.com/?p=74887

Good Luck!