The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

#288021
Hi,

The OpenGL Engine was upgraded in ARCHICAD 22 from the previous 2.0 version to 3.2 (which is more recent and efficient). As a result some older hardwares (GPUs to be exact) might not be able to work properly if they don't support this standard, or their driver is out of date.

As I can see you have a 21.5" iMac, but still with a low-resolution display, which could mean that it is a pretty old computer.

Could you check if you get a warning message (a yellow triangle with an exclamation mark in it) in the 'Work Environment > Advanced Redraw Options' window?

Does turning the 3D Anti-Aliasing off (in the same dialog) help?

Could you save a system report file (.spx) and send it to me in a private message so that I can see what hardware you have exactly?

Thanks in Advance,
#293057
I have the same problem. It's specific to OpenGL with Sun Shadows - changing any other settings has no effect.
I've updated to the latest Nvidia driver, but it didn't help.
An exclamation mark in the Advanced Redraw options relates to 2D, not 3D issues.
I'd appreciate any workaround tips, before I'm forced to 'regress' my projects to Archicad 21
Thanks,
Chris
Attachments
AC22 OpenGL sun shadows setting causes whiteout.jpg
In Archicad 22 OpenGL sun shadows don't work
#293839
Hello,

Sorry about the late reply. Thanks for posting that picture about your GPU information, that is really helpful.

In those windows we can see that it reports that the gpu/driver does not support some features of OpenGL 3.2. That is probably the source of the issue.

Up until ARCHICAD 21 we have been using OpenGL 2.0, but in ARCHICAD 22 we have upgraded to OpenGL 3.2 (it is faster, has more features, etc.). Apparently the graphics card in your computer does not support this version of OpenGL, so I think this is the reason it won't work properly.
The exclamation mark in the Work Environment gives you a report that is related to 2D Hardware Acceleration, but that is done by OpenGL as well, so if you see that report, that simply means that the GPU has a conflict with OpenGL.

I looked at the history of that GPU and it looks like it is from 2009 so it kind of makes sense that it doesn't support newer technologies. My best advice would be to upgrade the graphics card in your computer (it doesn't have to be an expensive one, just one that is more up-to-date and still has driver updates). This Help Center article can help you choose the right GPU for ARCHICAD 22.

Good Luck, Daniel