The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

#289217
I am experiencing a very frustrating slowness whenever I activate a command that requires a 'Finder' dialog box since upgrading to Mojave. Example commands where this occurs are; Open, Save, inserting files, setting publishing file paths, etc.
The dialog appears on the screen promptly, without delay, but then there's a freeze of about 3-5 seconds. And this happens each time I change levels in the folder structure.
My files are mostly cloud based (Dropbox), but I am not experiencing this behaviour in other applications - so I assume it's an ArchiCAD issue.
#289601
Hi,

I recall something like that happening to me before, but I can't see that anymore. Maybe it is because I am on the latest ARCHICAD update (build 4023). Have you tried that?

Also, if that by itself doesn't help, maybe check out the suggestions from this article as well:
https://helpcenter.graphisoft.com/knowledgebase/75345/

(it seems to be unrelated, but who knows...)

Regards,
#289606
I am seeing this too constantly on 4023 and tried the recommendations from the article without success.
#289999
Thank you for the suggestions.
I believe I am on the current versions of both Macos (10.14.2) & Archicad 22 (Build 4023).

I have used the suggested fix on a previous (unrelated) problem - on that occasion it worked. Unfortunately after trying the same fix this time, the problem persists.

Dave
#293048
Found a possible solution but to narrow down what was the correct item you could try, closing AC and going into System Preferences -> Security and Privacy-> Privacy, and uncheck every single item for AC then restart.
#293093
That seems to have fixed it!
I just tested a few commands that use a Finder dialog - Open, set publishing path, import surface jpg image - all worked without the freeze I had been getting in the Finder dialogs.

Thank you very much Ejrolon!!
#293110
I have for the second time followed Daniel's link recommending resetting the user folder to cover a possible conflict between the Apple HFS+ and APFS introduced with Mojave. It looks like this time it has worked, but I did also do a cold boot following the folder reset (renaming) before launching AC. There was a bit of an initial long delay but this was probably down to rebuilding the missing folder.

On the System Preferences front I declined any interaction when requested, as I thought it was a bit odd for AC to be making these requests. At present I have noted requests to access my Contacts, Calendars and Photos, all of which are unticked.

I will report back if further file access problems are encountered.

I am at this time running AC22 5003 UKI FULL on a 27" iMAC Late 2013 8Gb Ram with OSX 10.14.2