The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

By TheresaAPD
I am having a glitch in one file only (in version 22). I first noticed this problem because I tried re-linking a plan drawing on a layout (I always crop my first floor plan to look nice, then copy the drawing to another layout and re-link the drawing to the second floor plan so that the plans line up perfectly). The second floor plan jumped on the page and was no where close to aligning with the first floor plan. I did some investigating and learned that whenever I redefined the view settings (by clicking "Get Current Window's Settings" in the View Settings), my drawings change position on the layout. The drawing on the layout is set to have a "Manually resized frame." The boundaries stay in the same position as originally drawn but the drawing moves inside that frame. The problem seems to only be with plan views. I have compared a normal functioning project side by side with this one and I believe I have all the same settings selected. I tried saving new views, but those still had the same problem. I also tried saving the file as a solo project, but the problem persisted.

Graphisoft's "solution" was to redefine the view settings of the first floor, navigate up a story and redefine the view settings of the second floor so that they are both saved with the same zoom. I'm sorry, that is not a solution. I re-link every plan view to align perfectly on the layouts (floor plans, structural plans, mechanical plans, electrical plans, etc.). There are 3-4 plans for each category. I am not about to manually re-save all of those views with the exact same zoom and still risk things moving if a team member re-saves the view with a different zoom. Does anyone have any idea what might be causing this?
By DGSketcher
Are you using the Drawing's internal origin as anchor? This will stop views moving around if the drawing size or boundary changes.
Screenshot 2018-12-11 at 17.24.06.png
Screenshot 2018-12-11 at 17.24.06.png (27.51 KiB) Viewed 1353 times
By TheresaAPD
I have tested both checking and unchecking that box. The drawing will still move if the view settings are re-defined or if I re-link to a different floor.
By TheresaAPD
I have determined that the file is just corrupt. We were changing the orientation angle of some plans saved in the view map and when we saved one plan with a 90 degree orientation, all the views would then open with the 90 degree orientation. If we saved one view with a 0 degree orientation, all the views would then open with the 0 degree orientation. The odd thing is that the angle of the plans wouldn't change on the layouts (except for the view that was actually updated) so ArchiCAD definitely knew what orientation each view was saved with even though it wouldn't open with the correct orientation.

I fear the file is beyond repair so we are copying and pasting the corrupt file into a clean template file one story at a time. So far it seems to be working. Next we will copy all of our elevation/section notes into the new file. And then we will recreate the layouts.

If anyone has any experience successfully repairing a corrupt file, please share. I never want to rebuild a file again.
User avatar
By dkovacs
If the file is indeed corrupt, then it might be worth checking it out to verify. I have seen issues when the rotation of one view appeared on the placed drawing of other views, but not the other way around (the layout is fine and the views rotated).
If you can create a short video for me about the 2 issues (the jumping and the rotation on a specific layout), and send it to me with a PLA of your project (in a private message), I would be more than happy to take a look at it.

By afaria
any more info on this subject? I have two projets with the same problem, both teamwork projets.
thank you
By TheresaAPD
No - I sent my file to Graphisoft support and they were able to reproduce the problem in the file I sent but didn't ever come up with a solution. There was a 22 hotfix earlier this summer that fixed some of my problems. The drawing no longer jumps on the layout when I change the zoom and click "get current window's settings" in the view map. I still have problems with drawings jumping when I "relink" floor plans (for example relinking the first floor to the second floor in the layout book).
By afaria
We have asked every user to quit the projet (erasing local files), and then open and repair option with a local file from the teamwork projet. After sharing the repaired local file to the bimserver it was ok.
In summary: apparently opening and repairing does the trick.
By TheresaAPD
I found a copy of the corrupt file that I had saved and tried to use open and repair again. Unfortunately, that does not work for my file.

I know some coworkers have used open and repair successfully on other files (for various issues) so that is always a good thing to try.
By afaria
Tough, because it's really annoying and time consuming. Please let us know if you find any other clues.

Thank you.