The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

User avatar
By dkovacs
#293945
Hello Everyone,

It might be related to Tech Specs, but I don't think so. It is more likely that There's an OS-level settings or DLL stuck that messes with the context menus (like Davide Franco suggested).

What would be the most important as a first step, is that when ARCHICAD crashes, and the bug reporter comes up, you should send in a bug report (preferably with comments about what you were doing), and post the bug ID it gives you here, so that I can check the report in our system. I might be able to see what it could be related to based on that!

Thanks,
#296084
I have the same issue with a brand new Dell Mobile Precision 7730 (NVIDIA Quadro P3200).

The first and only thing that was installed on that machine is ArchiCAD 22. Luterally: I received the machine, patched it (OS + Vendor although there was no driver update available) and then installed Archicad 22 (fresh download).

The software is running in demo mode (the machine is not for me, the final user will install her own license).

The OS is Windows 10 Pro (1809) (EN).

The crash happens on right-click and on main menus (Files, Edit, Window, etc.) but not all: I can go in the Options and Help menus.

After the application crash, the crash reporter window opens briefly but seems to crash as well on its own.

Nothing can be found in the event log but the user's GRAPHISOFT folder is full of dumps and crash reports.

The crash reports are all about when looks like a null object reference (read Access violation with a low address) in GSRoot.dll with a stack trace that stops in the CHToUpper function.

I'm not a registered user of that product (not a user at all, as a matter of fact) since I'm preparing the machine for an Architect friend so I do not have any contact with Graphisoft (and can't, therefore, contact their support).

Resetting the machine does not help (makes sense since it's brand new).

Any suggestion about how to fix that would be welcome.

Edit: if it can help, I have a folder full of dumps and crash reports but since the crash reporter does not (apparently) work either, they are not sent over.
User avatar
By dkovacs
#296320
Hello StephaneGrobety,

Wow, awesome work you did there (very detailed report)!

If you could really send me the reports and the dumps in a private message, that would be amazing, it would help us a lot!

If you can't send it, and need an upload link, let me know!

Thanks in Advance,
User avatar
By dkovacs
#296348
Hello everyone,

We are looking into the logs, and as a first tip I have been told that it might be worth giving this one a try:
Go to the Region Settings of Windows 10, and turn off the checkbox in the picture.

Could you test if this helps?

Regards,
Attachments
image001.png
By MCZY
#296428
dkovacs wrote:Hello everyone,

We are looking into the logs, and as a first tip I have been told that it might be worth giving this one a try:
Go to the Region Settings of Windows 10, and turn off the checkbox in the picture.

Could you test if this helps?

Regards,
I'm working on a DELL G3 i7 8750H Nvidia 1050ti and had the exact same problem. After days of searching i found this Post and almost couldn't believe my eyes as i opended the menu bars without crashing.

I too can confirm that unchecking the box indeed solves the problem and i created this account basically just to bump this soluton, since it is nowhere to be found on a regular google search.

Thank you very much for the Answer!
User avatar
By Paul King
#301661
Same issue for me under windows 10 pro 1909

I can confirm that unticking the box under locale settings for windows (as suggested above) did work however.

No idea how it got ticked in the first place, or if it has been ticked by default, and if so how ArchiCAD had been managing without the crashes up until now. Possibly a windows update, or possibly a recent hard drive swap triggered something.

Note - a trap for young players is that if you happen to change locale at the same time as unticking that box before clicking apply, the box seems to tick itself again - so just do one after the other.
By John1028
#303184
Hello, same problem here. Please help:

Archicad was working on machine for 1+ years when suddenly it crashed when clicking on stairs to adjust it. Now Archicad starts normally, I can change views that are already open, move view, zoom in zoom otu, add new elements, but after clicking right mouse button for context menu, double clicking on the element, clicking on file / edit etc, gives me a crash of archicad. The same happens on Archicad 20 and on Archicad 22. I'm using windows 10. I have tried:

Restarting the machine
Repairing Archicad
Command prompt SFC (there was some curruptios, but it fixed it)
Command prompt DCIM (there was some curruptios, but it fixed it)
Uninstalling last windows updates (can't reinstall security update)
Reinstalling MS Visual C++ 2010/2012/2013/2015
Repairing intel Redistributable C++
Installing newest intel graphic drivers
Reinstalling Archicad


Any ideas? Anyone else have got similar problem? How did you solve that? I really don't want to reinstall windows...:

Action Log:
00 0x5DB5BDCE 0x00001E0B 0x00000000 0x00000000
01 0x5DB5BDA4 0x0000430C 0x00000000 0x00000000

Command Log:
0 2019/10/27 16:54:31 DrawingsAutoUpdaterDoAutoUpdateDrawings2Command
1 2019/10/27 16:54:30 DrawingLinkStatusCheckerDo2Command
2 2019/10/27 16:54:26 OpenNormal3DViewCommand
3 2019/10/27 16:54:26 PNOpenViewCommandClass
4 2019/10/27 16:54:22 CreateSlabCommand
5 2019/10/27 16:54:05 DrawingsAutoUpdaterDoAutoUpdateDrawings2Command
6 2019/10/27 16:54:05 DrawingLinkStatusCheckerDo2Command
7 2019/10/27 16:54:02 DrawingsAutoUpdaterDoAutoUpdateDrawings2Command
8 2019/10/27 16:54:02 DrawingLinkStatusCheckerDo2Command
9 2019/10/27 16:53:48 DelayedEventHandlerCommand
10 2019/10/27 16:53:48 DrawingsAutoUpdaterDoAutoUpdateDrawings2Command
11 2019/10/27 16:53:48 MarkerLinkManagerMultiEventMessageDoCommand
12 2019/10/27 16:53:48 ChangeManagerMultiEventMessageDoCommand
13 2019/10/27 16:53:48 DrawingsAutoUpdaterDoAutoUpdateDrawings2Command
14 2019/10/27 16:53:48 DrawingsAutoUpdaterDoAutoUpdateDrawings2Command
15 2019/10/27 16:53:48 DrawingLinkStatusCheckerDo2Command
16 2019/10/27 16:53:48 DrawingsAutoUpdaterDoAutoUpdateDrawings2Command
17 2019/10/27 16:53:46 ScheduleSyncronizeEventHandlerDoCommand

Exception code: C0000005 ACCESS_VIOLATION reading location: 0000000000000010
Fault address: 00007FFD731DB3FA 01:0003A3FA GSRoot.dll
TOS address: 0000009D9430D570 00:00000000
User avatar
By Paul King
#303185
Have you tried changing locale settings, as suggested above?

Worked for me.