The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

By DanielH
#294383
Our team (8 people) is working on a condominium project that has a large number of flats (~50/storey). Each flat type (eg. studio, one bedroom, two bedroom, etc.) has its own individual teamwork file and different plans are on different storeys. We place these storeys as hotlinked modules into the main file (which has all the other non apartment specific structures).

We didn't have any problem while working on the outer walls or the basement, but after we started placing the flats, Archicad noticably slowed down on all of our computers (with different specifications).
Now, for example: if I drew a circle, I had to wait 6-7 seconds between finishing the circle and the circle actually appearing. Same when moving or deleting walls, slabs... anything. This problem persists if I hide the hotlinked flats by turning their layer off.
What causes this problem and how could we solve it? Thanks in advance!
By DanielH
#294437
I've thought this forum was more helpful. But I will be my own help, again.. sort of.
I've tried everything that others suggested in older topics.
- turning off background update - it was already turned off for me
- turning on hardware acceleration - it was turned on already
- deleting preferences from appdata and user folders and reloading default archicad profile and teamwork projects
- turning off all virus protection applications
- updating bim server and archicad to newest version

None of these helped, so it has to come down to file size.
I saved a pln to my computer, unlinked hotlinks and checked if it was still slow - it was. Then I deleted all of the flats from all the storeys, then saved and restarted - it is fast again. The teamwork file is 2270 MB and the one i cleaned is 630 MB.

With this additional knowledge, could somebody suggest something? Productivity is literally killed when we have to wait 6 seconds after every operation, rather frustrating too.
One more thought: The number of 3D element intersectiuons (eg. too much walls for AC) can not be the problem, because 2D worksheets are slow too.
By DanielH
#294441
We called our seller's support, they suggested that the problem may be caused by a poorly written object's parameter, so we tried to search for problematic objects. After several hours it turns out that the problem has no connection to objects, but as I thought first, the hotlinked files. This is what i did:

1. Save main teamwork file to pln.
2. Open saved pln (hotlinks still linked) - slow.
3. Unlink all hotlinked files and save a new pln, then open it - fast.

The file of step 3 has all the information in it, all the flats, but unlinked. So the difference between slow and fast files are linked or delinked (unlinked? I don't know how english AC calls it...) files.

After replying to myself for the second time, I could really use some suggestions on how to solve this issue.
#294510
Have you modelled the furniture within each of the flats? If so, I would turn them all off while working.



Ling.
#294511
It is very hard to say without having the actual files you are working on.
Hotlinks will obviously slow the master file down as you are linking to an external file - or in you case it sounds like 100s of external files.
I have had some issues with hotlink speeds in the past and I found that it is important to make suer all files are saved in the same version of Archicad.

Also make sure that you are not using any old version or migrated libraries.
If you are then every time Archicad needs to access that module, it opens it in the background and has to migrate all of the libraries before you can do anything with that module.

Here is a post where I was experiencing slowness as well.


viewtopic.php?f=37&t=62731&hilit=module


I don't know if saving all the modules in the same version and making sure they all have the same library (& not migrating libraries) will help or not, or whether it is just the shear number of modules you have that is the problem.

Barry.
By DanielH
#294517
Thanks! We couldn’t solve it yet, but we are trying.

Ling, we set every 3D object first to simple then to off in 3D but it didn’t help. Turning the layer off didn’t help.

Barry, we have 14 hotlinked files and 5-15 flats in each at max. (460 flats in the house). All hotlinked files are made in AC20 too. We noticed that the hotlinked files had 2GB in library parts, but deleting all of that didn’t solve the problem.
User avatar
By Riven
#294709
Our office designs 3 to 4 story apartment buildings containing 100 to 200 units typically. I've witnessed some slow down after our entire office migrated from V20 to V22 this year, but nothing show-stopping about the slow-downs. We tend to limit the number of individual unit types (i.e. modules) to something like 10 to 20 tops.

Our strategy to solve hotlink-related slow-down problems and other issues related to external hotlink modules, or .mod files has been to incorporate ALL the modules into the project file itself. I've heard it called the "iceberg" method. This eliminates any use of external .mod files referenced in the project, and ensures the same libraries are used for all hotlink modules all the time. Maintaining your project libraries would be limited to the libraries of the host project only; no need to open a separate instance of ArchiCAD to manipulate/modify external files.

I understand this may not represent a fix for your slow-down issues currently, but if fixing your libraries hasn't yet helped, then I recommend making the switch to this sort of hotlink management workflow. :wink:
By DanielH
#294826
Thanks for your help!
We've sent the files to Graphisoft and finally we have an answer to this problem:
#221671
Graphisoft knew about this problem and they fixed it in later versions (Archicad 21 and 22), but not in AC20.

So, they basically suggested us to buy AC22... Unfortunately we don't have other options because our team doesn't know how to use Revit (and the project was started in AC). It is nice to know problems like this aren't fixed in affected versions. We are concerned AC22 has some other bug or problem that won't be fixed either and we are stuck buying every new version just for the fixes... Should have stayed at AC12.