The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

User avatar
By thinhphamkts
#295862
Hello everyone,
Could you please help me with this issue (as in attached image)?
As you can see the letter N is shown differently, although all the properties are the same with other letters. If I change it onto another letter then it appears normally. So, it is only happening with letter N.
Attachments
Capture.PNG
User avatar
By Barry Kelly
#295908
I am assuming you are using an object to do this.
Is it the 'Text 3D 22' object that comes with the standard library?
If so what font are you using?

It looks like it is having trouble interpreting the hollow inside the N.
I assume if you use a different font that is OK as well.

Barry.
User avatar
By Lingwisyer
#295909
How have these been made? 3D text object? My first thought would be that the surface is degenerating due to the acute angles. Do other letters such as V and M have the same issue?



Ling
User avatar
By thinhphamkts
#295923
Hi,
I used normal 3d text.
I figured it out that it happens with few other letter when I make it become BOLD. You can see in the attached file. The "N" has to be normal style.
I use font "Swis721 BlkOul BT Greek"
Attachments
Capture.PNG
User avatar
By dkovacs
#296139
Hi,

Yeah, it clearly looks like at the sharp angles on the outside of the N, the lines cross themselves when you set it to bold. I don't have such an empty font (and I can't find that specific font online), but I think this is not a generic issue, but a problem with this specific font design.

As you can see in the picture of the non-bold version, right before the corner where it goes wrong, it has a slight change of angle. When you set the font to bold, the edges will be offset, and because of this change of angle, it will intersect itself. This results in a degenerated polygon, so the surfaces fail to properly generate.

Please try it with a different font, or avoid using the bold option for this one. If you need this font and need the letters to be bolder, you can still convert them to morphs and change them manually.

I hope you will be able to work on with this information.

Regards,
User avatar
By Barry Kelly
#296175
Sorry I never got around to checking this out.
I don't have the BOLD option in my 3D text object - it is probably an old version.

The standard font works for me but I don't have the 'Greek' version if that makes any difference.

3D_text.jpg

There is a small curve in the internal corners of the 'N' that maybe is what is causing the problem when the bold font is chosen - creating an invalid polygon.

3D_text_2.jpg

Barry.