The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

#301162
I've been trying to solve this problem for months now. It might sound like I'm a little clumsy, but I feel pretty strongly that my workflow is good practice:

I press 'ESC' multiple times to clear all tools and selections to prevent mistakenly moving or editing any unknown selections. Pressing ESC once clears selections, pressing it twice de-selects any active tool, but then if I press it three times (or less if nothing is selected, and no tool is selected), it causes my "full-screen mode" to minimize— it is driving me absolutely insane. Sometimes I just like to press Esc to be absolutely sure that nothing is selected outside of the current view.

I've changed the minimize/maximize to full-screen command to 'ctrl + esc.', which at least lets me re-maximize after the window annoyingly minimizes.

I've changed my OS keyboard/shortcuts/app shortcut: 'Exit Full Screen' key combination to 'opt + shift + esc' and that has not stopped AC from minimizing from full screen with just the ESC button pressed. I really really want to stop my Full screen mode from minimizing when I only press ESC.

I've also reinstalled AC and then re-set these key-combos. That has not helped.

Please please help!!! :cry:
#301165
Hello,

We have the same configuration and I use Esc button like you do but I never have this kind of problem so I think it's a macOS configuration.
I invite you to check your MacOS parameters. Perhaps there is a shortcut about showing the Desktop (with ESC).
System Properties/Keyboard/Shortcut/Mission control/....
#301170
Here's a screenshot of my current mission control settings, mission control keyboard settings, app shortcut settings, and AC Shortcuts PDF.
Attachments
Screen Shot 2019-08-28 at 10.50.59 AM.png
Screen Shot 2019-08-28 at 10.52.26 AM.png
Screen Shot 2019-08-28 at 10.52.53 AM.png
AC Shortcuts PDF
(451.48 KiB) Downloaded 3 times
#301171
As a side note: no, I'm not mistakenly pressing the F1 key, which doesnt work without pressing the cmd key anyway... (using a logi Craft Advanced Keyboard)
#301174
I tried using the builtin keyboard (esc is on the touch bar), and it still minimized after pressing ESC. I also had an apple keyboard that I used to use, and I'm pretty sure the same thing happened.
#301176
Doing a quick test. Pressing ESC click in Mail and Safari Apps causes them to leave "Full Screen" but in my case AC does not minimize on hitting ESC so there must be another setting that is causing this.
In my KBS for AC I have the ESC key mapped to the ARROW tool so you could try that.
#301179
Ok, so, I've tried it on another computer, also a Mac, same version of AC, all the same settings for OSX and AC.

This is what I've realized: it happens with files that are big enough to take some processing time for certain commands; when AC is in mid-command-processing—even if the little watch-cursor doesn't come up because the particular process is quick—if I press ESC, the AC window will exit full screen.

I can press ESC multiple times when AC is not processing anything at all, and ESC will not cause exit full screen. I can also press esc with a tool selected, a marquee selection and object selected, and after three ESC presses, AC will not exit full screen.

This all being said, I really hope there is a way to stop AC from existing full screen when I press ESC under any circumstance, even if AC is in mid command-processing.

Any thoughts? :?