The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

By AdamVlcak

Did someone had to deal with misplacement of snap points of 3D object? Do you have any suggestions what could be wrong with my .pln file? I am unable to accurately manipulate with all 3D objects. This problem occured randomly. This for example is custom made truss profile I made. I am able to further edit all of my objects in 2D mode but this bugs me everytime I try to do something in 3D.

Thank you in advance

archicad - graficka chyba v 3D .png
This is what I would try.
Switch from the OpenGL engine to the Internal (Vectorial) engine in 3D to see if that makes a difference (not sure if it will).
Update your video drivers and restart your machine.

User avatar
By Barry Kelly
mikas wrote:
Tue Nov 12, 2019 8:36 am
Or You might have your model too far from the project origin.

Of course.
I always forget about that as I always model right next to the project origin.

By AdamVlcak
I did change openGL to vector engine and it works! But is there any way how to....perhaps reset openGL settings? I do prefer working in opneGL over v.e.
I also tried to change position of 0,0,0 but it did not worked.
Thank you guys for your replies.
(openGL on left, vector engine on right)
open gl.PNG
vector engine.PNG
Last edited by AdamVlcak on Tue Nov 12, 2019 5:31 pm, edited 1 time in total.
User avatar
By Barry Kelly
As Erwin said, you will need to move the model close to the default project origin, not move the origin to the model as that is just a 'user' origin - the real project origin that everything is calculated from is still too far away.

If that doesn't work then I would say it is an OpenGL issue.
Try the driver update (and restart your machine).