The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

By valentinlegoupil
Hello everyone,

I have an issue with Archicad 23.
It's recent because i never had this issue before.

When i do any action i have one second of loading that i never had before. (like select an tool, etc...)
I can't put a video here so i have a video on youtube :

i have an insane PC so it's on Archicad the problem.
I put a screen in attachment.
If you have any advice or information thanks you very much.
I wish you a nice day,

User avatar
By mnguyen

Thank you for sharing the issue and I am sorry about the experience!

From the video, I can hardly pinpoint exactly what is causing this issue. There are many things that can affect a software's performance. I would like to check a few things:
- Is the computer running low on RAM/C Drive storage while ARCHICAD is running?
- You never had this issue, meaning ARCHICAD 23 runs well on your machine before? Did you have an OS update recently?
- Is there any extra Anti-virus program/Firewall on your computer?
- Are you running ARCHICAD via a virtual machine/remote desktop/VPN connection?

Thank you very much for your help!

Best regards,
Hello Valentin,

What is your archicad environment parameters ?
Did you try to change it ?
I do not see this kind of problem with macOS on any devices and OS (and with old devices and OS too)
Between you hardware and Archicad there is an OS, so which is your OS ?
What are your graphic devices (cards and screens) ?
There are some windows parameters to check :
User avatar
By Barry Kelly
I had one of my users experiencing delays as well and tried to set exceptions for Graphisoft programs in the anti-virus software, but it really had no effect.
So I had the IT guys look into it.
Seems it may be a video card setting.

We use Nvidia cards and the following seems to work.

Start – Nvidia Control Panel
3D settings
Set Power Level as Maximum Performance
3D Rendering for Auto to the Graphics Card.

It may be the same for other brands as well.

Maybe adjusting the '2D hardware acceleration' in the Work Environment (Advanced Redraw Options) may also help - I am not sure.

User avatar
By sboydturner
You say you have an insane PC, are you running one of the new high core count Ryzen / Threadripper CPUs? If so it may actually be a RAM issue as these CPUs will perform poorly if they do not have enough RAM, I’d have a minimum of 64Gb but preferably 128Gb for any 16+ core CPU
Hello everyone,
First thank you all for your responses

Upon reflection, here are the changes I made that may have created this problem:
- I update Twinmotion (2020.1)
- i changed my screen

I tried what you recommended without success. So I put you the screenshots of:
- My PC config (Windows OS)
- My screen config
- My NVIDIA config

Thanks evryone, i'm waiting for your answer.
I wish you a good day,


My NVIDIA config :
Rapport Informations sur le système NVIDIA créé le : 04/02/2020 11:09:21

Système d'exploitation : Windows 10 Home, 64-bit
Version de DirectX : 12.0
Processeur graphique : GeForce RTX 2060
Version du pilote : 436.02
Type de pilote : Standard
Version d'API Direct3D : 12
Niveau de fonctionnalité Direct3D : 12_1
Noyaux CUDA : 1920
Horloge principale : 1710 MHz
Débit de données mémoire : 14.00 Gbit/s
Interface de mémoire : 192 bits
Largeur de bande mémoire : 336.05 Go/s
Mémoire graphique disponible totale : 22495 Mo
Mémoire vidéo dédiée : 6144 Mo de GDDR6
Mémoire vidéo du système : 0 Mo
Mémoire du système partagée : 16351 Mo
Version BIOS vidéo : 90.06.2E.40.1F
IRQ : Not used
Bus : PCI Express x16 Gen3
ID de périphérique : 10DE 1F08 37551462
Référence : G160 0042


nvui.dll NVIDIA User Experience Driver Component
nvxdplcy.dll NVIDIA User Experience Driver Component
nvxdbat.dll NVIDIA User Experience Driver Component
nvxdapix.dll NVIDIA User Experience Driver Component
nvCplUIR.dll 8.1.940.0 NVIDIA Control Panel
nvCplUI.exe 8.1.940.0 NVIDIA Control Panel
nvViTvSR.dll NVIDIA Video Server
nvViTvS.dll NVIDIA Video Server
nvWSSR.dll NVIDIA Workstation Server
nvWSS.dll NVIDIA Workstation Server
PhysX 09.19.0218 NVIDIA PhysX
nvGameSR.dll NVIDIA 3D Settings Server
nvGameS.dll NVIDIA 3D Settings Server
nvLicensingS.dll NVIDIA Licensing Server
nvDevToolS.dll NVIDIA 3D Settings Server
nvDispSR.dll NVIDIA Display Server
NVMCTRAY.DLL NVIDIA Media Center Library
nvDispS.dll NVIDIA Display Server

User avatar
By Barry Kelly
You say you have changed your screen (monitor?).
I looks like you now have a hi resolution monitor.
Was that the case before as well.
Can you change back to the old one?

I have no idea if that will make any difference.

Because you have a hi res monitor, are you scaling the display so it icons / fonts appear larger?
If so try setting it back to 100%.
Again I have no idea if this is the solution, just trying to come up with some options.

User avatar
By Lingwisyer
Troubleshooting 101: Turning if off and on again.

If it happens again, check your Resource Monitor. Maybe you have a memory leak or something, of which was killed when you restarted.