The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

#309445
So you are saying that when the external monitor is not attached, ARCHICAD 22 runs fine, but when you attach the external monitor, AC22 crashes during startup?
#309496
Hi Laszlo,

Thankyou kindly for your response. :D

That is correct if i open archicad 22 on my laptop its fine.

When i plug the external screen in and then open a new Archicad 22 directly from my new screen (HP Pavilion 32HD) then it crashes. Also if i open archicad back on my laptop screen, while the external screen is plugged in it does not crash....

I noticed it also when i purchased a 4K screen as well (i have purchased and returned about 8 different screens). It bizarre i asked my Archicad Manager in my other office and he has never heard of it.

I sent the error message to Graphisoft last night
AC22-2020-04-09-12-56-57-9643

When i use an external screen of low quality it works fine.

I decided to take a big step and last night download my Archicad 23 and it seems to be working fine with Archicad 23, however all my projects are in 22 which would be good to retain as a workable option. :D
#309611
What are the specifications of your computer (Processor, RAM, graphics card (incl RAM) and storage) ?
Maybe graphics being over stressed whilst starting Archicad

Regards
Scott
#309619
Hi,

Thank you for sharing the issue and I am sorry about the experience!

Based on the Bug ID, it looks like there is something wrong with the graphics card when you open ARCHICAD 22 using the external display, either the machine is trying to use the wrong card, or Antialiasing must be turned off. Since you are using macOS, here are a few suggestions to try:
  • Please disable the automatic graphics card switching with this tool: https://gfx.io/
If the above tool cannot help, antialiasing should be switched off in the preferences. Please follow the steps below:
  • In the respective AC folder under
    Applications/GRAPHISOFT/ARCHICAD 22 XXX/Defaults/ARCHICAD/WorkEnvironment/User Preferences/Standard User Prefs 22.xml
  • The following line needs to be adjusted:

    <AntialiasQuality>1</AntialiasQuality>
    <AntialiasQualityOpenGL3D>1</AntialiasQualityOpenGL3D>

    The above "1" needs to be changed to 0.
Afterward, please do a Preferences cleaning

Note that in this case this only worked after a reboot of the computer.

Please let me know if the above suggestions help. Thank you very much!

Best regards,
Minh
Attachments
change.png
XML edit