The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

#309545
I keep getting this pen indicator in my info box. This creates a half tone pen that I then have to select and change to a real pen. How can I avoid this happening?
Attachments
Pen Setting.png
Pen Setting.png (1.67 KiB) Viewed 433 times
#309658
What is it the pen setting for?
All elements (tools) or just one in particular?

Barry.
#309672
I have never seen this.

So are you saying that if you fix it with a proper pen, it will revert back again later while working on the same file?
If not then somehow the default has become corrupted and just needs to be reset and the file saved.
Then hopefully it won't happen in that file again.

If you ALT click on an existing line, does it reset the tool default settings?

Barry.
#309673
Barry,
Once I change it to a proper Pen number it will keep it. I seem to keep running in to it on different lines. I can transfer the settings from a different line.
The drawing was started from scratch in this file and nothing from the outside has been copied in. I'm also only working in one pen set. This is a remodel so I am using the renovation filter but that doesn't seem to matter as some of the lines are existing and some are new and changing their state doesn't change the line.
I have added a couple more screen shots for reference. You will notice that the open pen box shows a non existent pen 256.
Attachments
Pen Setting2.png
Pen Setting1.png
#309675
I have never seen this extra pen and have no idea where it may have come from.
The only extra pens I know of are for fill backgrounds (pens 0 & -1).
I have also seen an RGB pen for zone fills, but never a pen 256.
There is no option to even click on pen 256 for me - there is just nothing there.

If it is just in this one file then I would suspect some sort of corruption in the attributes.
Actually it would be interesting to see what is listed in the attributes for the pen sets.
Is there a pen 256?
I am guessing nothing will show as pens 0, -1 and the RGB pens do not show in the attribute manager.


Barry.
#309679
You'll sometimes see this pen, when it's a custom RGB colour that's not in your Pen Set.
For example, copy a shaded element from an elevation, paste into floor plan. The fill will use this custom RGB pen.
But I haven't seen that pen icon appear before myself (only the RGB wheel). Maybe related...
Attachments
Screen Shot 2020-04-14 at 11.45.10 AM.png
#309933
Hi All,

I hope you are doing well during these trying times.

Thank you, Brad, for sharing this issue! I have never seen this Pen symbol appearing to me. I haven't found it reported to our database either, therefore this must be a rare issue.

I exported the attribute to an XML file and edit it to include a pen #256, still I cannot import the #256 pen to the current file. As Barry suggested, can you see the pen #256 in the Attribute Manager?

Could you share a sample file for a closer look? Thank you very much and I look forward to hearing from you soon!

Best regards,
Minh