The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

User avatar
By daviiiiidave
#315073
What happend here? Its not working.

I cant use the magic wand on splines cause archicad dont stop working and calculating.

It doenst work with fills, it doesnt work with mesh nor with morph.

I had to kill archicad the 100th time via task manager while trying to finish some competition plans.
Its so messed up.

Seems like somebody messed up the code for the magic wand calculation.
User avatar
By mnguyen
#315078
Hello,

Thank you for the report and I am very sorry about the experience!

I made a Spline used magic wand to make a fill and a morph out of it. Everything was quick and snappy. I'm using Archicad 24 INT on Windows 10.

I'm wondering if you can replicate this issue on a brand new file? It could be that there was corrupted data in the existing file that makes this process slow.

Looking forward to hearing from you!

Best regards,
Minh
User avatar
By daviiiiidave
#315079
Archicad support told me to split the splines.

but its still a pain in the ass and im waiting like 20mins to get a part *filled*

its urban planing and its not working. frustrating.

Image
User avatar
By mnguyen
#315080
Hi,

Could you share with me the file for further investigation? It looks really complicated!

Let me know if you'll need a secure link to upload the file to.

Thank you very much!

Best regards,
Minh
User avatar
By daviiiiidave
#315082
i wrote you a DM
User avatar
By sboydturner
#315093
If this is an urban scale project it could be a distance from origin issue, I cannot see the origin location on the attached image but if 000’s of meters away from what we can see that could be the issue as the numbers for calculations of the splines / fills get really large and prone to error
User avatar
By mnguyen
#315134
Hi,

Thank you for the file! The slowness can be seen in both AC23 and AC24, so this is not an AC24's issue

I found out that, due to the complexity of the spline, it causes a huge delay at Graphical Feedback phase. In order to avoid this, please navigate to Options > Work Environment > Selection and Element Information, switch off "Highlight element before selection and Magic Wand". The process should be a lot faster now.

I attached a GIF about how to do it. Should you have any further question, feel free to ask me again!

Best regards,
Minh

Image
User avatar
By daviiiiidave
#315137
been there done that.
0,0 is right in the middle of the model.

it was the first approach I tried.
We tried like everything. even going back to AC 22.

the area is like 350m x 300m.

I'm really disappointed with AC since the weekend. we had so much trouble doing the urban planing in AC.
I can't imagine doing much bigger and complex projects in AC. it was extremely slow. we tried everything to make the thing not so complex. the support told us in a joke to change the design which made me furious. software shouldn't restrict what to design.

The moment we switched to rhino+grasshopper it was fluent and speedy (like 4 hours before deadline). Processes AC couldn't handle rhino did in seconds. (for example, fill a Spline with a surface/fill/hatch or show us the corrupted part to heal the spline)

I don't know how to recommend AC to my students I teach 2 times a year. Their projects are way more complex and out of the "standard" world. Right now I don't believe AC can handle it and I think they will all stay in Rhino.

We couldn't produce the results we had in mind. we are going back to rhino+grasshoper+illustator for this kinda work. And I'm wondering cause our design is so basic. Just some cubes, some trees, and this wavy road.

This blue loading ring has burned into my retina.

(1)The site model tools in AC are non-existent. If anybody says "Use the mesh-tool", I will explode :D
(2)ParamO was a really good toy to use. I see so much potential. :!:
(3)Working on drawings was a pain in the ass on this scale
(4)visualization of 2D drawings was cruel and every change took 15min+.
We need CMYK, we need hex color codes, we nee a way better handling of jpeg, png etc, we need transparencies, we a decent layout tool with the possibility to create a whole layout with different pages in one view like the artboards in Illustrator and a lot more
(5)we need different view styles for working (low quality, mid, and presentation) like in InDesign or Illustrator.
we don't need the whole time the perfect presentation view which is slow af.
(6)These precalculation operations like the magic wand tool are destroying the fluent work. I had to tape my space to avoid pressing it and to avoid the precalculations for the "boundaries" of the magic wand tool. cause every time I hit the space in the wrong place, the calculation started and ended up me killing the AC process via task manager and this happened like 50+ times.

Till the weekend I was like "I wanna do everything in AC cause I believe in it and I think we can do it"... but since last weekend I'm questioning it a lot. The performance of AC was really really bad and costs us a lot.

I told my colleges if AC was a game the community had ripped it apart and nobody would have played it.
I would have uninstalled it immediately and cried for some long time spending 5k for this.

You can see I'm really in a bad mood talking about it cause they asked me if we can do it in AC and I told them I'm pretty sure. This was a bad choice and a bad recommendation. it has cost us all a little bit of our life time.
User avatar
By daviiiiidave
#315138
mnguyen wrote:
Mon Aug 17, 2020 9:35 am
Hi,

Thank you for the file! The slowness can be seen in both AC23 and AC24, so this is not an AC24's issue

I found out that, due to the complexity of the spline, it causes a huge delay at Graphical Feedback phase. In order to avoid this, please navigate to Options > Work Environment > Selection and Element Information, switch off "Highlight element before selection and Magic Wand". The process should be a lot faster now.

I attached a GIF about how to do it. Should you have any further question, feel free to ask me again!

Best regards,
Minh

Image
Thanks for your help and your solution. I'm really happy GS is trying to solve user issues.
But to be honest. You call this spline complex. In my world, this spline is not complex. AC shouldn't have problems with it.

But I tried your solution. you are right it's working super fast. even with the mesh tool, it took me just seconds to fill the spline. and to create what I was looking for. Thanks a lot for your approach. So now GS has to work on this highlighting thing.