The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy

#323937
A couple weeks ago I opened up an AC 22 project and found all the cabinet work I'd just done was gone. Everything else was fine. I turned on all layers, turned on all stories, turned off all renovation filters, etc, and nothing fixed it. I opened up a previously saved copy that had the cabinetry, and same thing: cabinetry missing even though I saved it with all the new cabinetry there. That suggested the files were fine, but that AC 22 had some bug in it that hid the cabinets no matter what copy it opened. I quit and relaunched AC, no luck. Shut down and restarted the computer, no luck. A couple days later I opened it up again and for some reason everything was back to normal.

Today I opened it up again, all the cabinets were still there, but one floor, the upper half of a run of custom stair treads and rails (made from standard walls, posts, and beams), and a bunch of posts and stringers were missing. Again I turned on all layers, stories, etc, and nothing fixed it. I tried 'Open and Repair Selected File', same missing elements. I saved a copy and opened it in AC 23, same missing elements. I archived a copy and opened it in AC 24, same missing elements. That suggested my copies of AC are fine.

My computer is old but runs perfectly. All other AC files I'm working on behave normally. All other software runs normally. I've shut down and restarted a number of times. This suggests my computer is fine.

Any idea what's going on?
#324017
Here are two screenshots, "before" from the file I uploaded to BIMx before the glitch, "after" from the current state of the AC file -- floor is gone, wall and structure gone, stair stringers gone, half the stair tread standoffs gone, several glass floor panels gone including one's SEO effects on the upper floor.

None of what's missing in the current model gives any clue as to why. It's not group related, layer related, structure related, renovation related, element related, object related, location related, not 3D filtered, not 3D cutaway, not anything I can think of.

And now the welder is on site and the contractor is asking for a steel detail revision for the stair stringer brackets which are no longer in my model! Aaaaaaahhh!
Attachments
before.jpeg
before.jpeg (270.29 KiB) Viewed 141 times
after.png
after.png (1.08 MiB) Viewed 141 times
#324026
Dear Geof,

Thank you very much for the report and I am very sorry to hear about the issue!

Would it be possible that, when this issue happened, the BPN file was opened instead of the PLN file? Is it a teamwork file or a solo file? Do you happen to synchronize the file with any cloud service?

Furthermore, if the BPN file is available, could you open it to see if the floor slab and stair is still there?

Looking forward to hearing from you!

Best regards,
Minh
#324045
Thanks Minh,

I wouldn't have opened a .bpn since only the .pln shows up under "Recent Project" when I start AC. I did just open the .bpn but it looks the same. This is a solo file. Not synch'd with a cloud service, but backed up on one.

I've taken an old backup, archived it and opened it in AC24, adding the cabinetry from a later file. I'll see if that's more stable. I've given more detail to Örs at NA Tech Support.

Geof