The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Discussions about any other product with no dedicated forum - MEP Modeler, ARCHICAD Goodies, 3rd-party Add-Ons, operating systems, products of other vendors, etc. (Example: Which Add-On is the best for creating special Stairs?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

The designation of the Road Slope does not show accurate. The attached image shows that the rise of one section is -6.64 feet, which is accurate (103.93' minus 110.57') and shows a run of 49.21 feet. The Run is actually 44.26 feet as noted in the straight stretch length.

Am I just not reading this information correctly?
AT Road Section.JPG
Please, check the latest update on web site.
I'm quite sure we already fixed this bug...

Let me know...

I have the download of the ArchiTerra

It contains 147 files. Do I copy them ALL to the ArchiTerra 2.0 Folder under the ArchiCAD Add-ons folder?
:?: :?: :?:

If you well downloaded the zipped file and well expanded it you should see an "ArchiTerra 2.01" folder.
Delete the previous one from your ArchiCAD Add-ons folder and use this one just expanded...

Now it's very late here... see you tomorrow!
Thanks for the late night advice it must be almost midnight in Venice (Venezia)
Even With the Update (ArchiTerra 2.01) the data in the Road Slope is not reported correctly.
Dear Jay,

you are right!
Today or tomorrow I will upload a new maintenance update that fix this bug (it occurs when you are using Imperial unit :( ) and implemement also a new function: when you import a TXT file you will be able to swap the X-Y coordinates.

Dear Jay,

You can download the latest mainteance update where:
1. slope percent bug is fixed
2. you can swap X-Y coordinates during TXT import

Please, let me know if it will solve your trouble

Thank you for the being fast on a fix. You have great customer support :D

The fix seems only partial. For polylines without any intermediate (points between beginning and end points) the slope shows correctly. For ploy lines that are segmented, only the First segment slope is correct. The other segments are not in the attachment the first segment is correctly noted as 6% (Although it is a bit confusing to have the height difference , in this case 1.12', shown above the percent slope). The next two segments should be 15% each not 10%.
incorrect Slopes.JPG
“Thank you for the being fast on a fix. You have great customer support ”

You’re welcome but I think this is our job (we choose it!) and fixing the bugs the users discovered is our first priority.
Once again you are correct! Unfortunately nobody, till now, never realizes about this bug so, it is here from the very first release of ArchiTerra.
I already fixed it but, this time, I really don’t want to bore the user with another maintenance release till I won’t be sure the trouble is solved (I uploaded three different versions in the past three days!).
So, I’m going to directly send you the update (only the APX file that you have to substitute to the previous one) to your e-mail address.
Please, could you be so kind to say me if everything works fine using this release (I tried and it seems to be ok… but you are a wizard in finding out strange behaviour! :wink: )?
If your final report will “approve” this release, on next Monday I will upload it at