The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Tips and tricks, suggestions, problems. (regularly monitored by Administrators)

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy, apolgar, GSHQfadmin

#283029
When I tag something a 'code' in a post it shows in it little code box, but all the formatting has been removed.
carriage returns, tabs, spaces have all gone - which are quite important when it comes to code.

This is what it looks like while composing the post.
code_1.jpg
And this is what it looks like in the final post.
code_2.jpg
I am sure it used to be fine before.

Barry.
#283030
There is definitely something going wrong.
My previous post should all be on separate lines with the text between the images - not after the image.

Barry.
#283075
PeterBocz wrote:
Wed Jun 27, 2018 1:30 pm
Code formatting (keeping white-space) is fixed.

I'm not sure about the line-breaks after bbcode element, but you can insert a double line-break as a workaround.
Thanks for looking into it and the work around.
But please keep looking into it as it used to work.

It is not so much the line breaks after the bbcode element, it is it line breaks within the bbcode when tagged as 'code' - the code is unreadable.

Maybe it is caused by the same problem and maybe the double line break would work there as well - but that will be a pain especially when copy/pasting the text to/from GDL.

Barry.
#283076
Even the quote post has changed.
Didn't it used to show who the quote was from?

Now when composing/editing the post it shows ...

(quote=PeterBocz post_id=283047 time=1530102618 user_id=90571)

I am sure it used to just be ...

(quote="PeterBocz")

I have changed the brackets so it doesn't show as a quote - which it shouldn't have done as I didn't end the quote with the usual (\quote).
Something has definitely been changed recently.

Barry.
#283084
Barry Kelly wrote:
Thu Jun 28, 2018 2:01 am
Even the quote post has changed.
Didn't it used to show who the quote was from?
Yes - and this happened just within the last week or so. Peter, this needs to get fixed - in complicated threads, there are quotes of various participants and now there will be no way of knowing who said what... :-(
#283106
I'll look into it. We performed a minor upgrade in the forum engine over the weekend which might be the cause of problem. Quoting should work as you expect, showing the quoted person's name.
Displaying white-space properly is an unrelated issue which is fixed via CSS, but feel free to post examples if you disagree..
#295526
The quote tags are back so now we can see who and when they are from.
Even in all the old posts.

Yay :!: :D

Barry.
#295534
Barry Kelly wrote:
Wed Jun 27, 2018 2:41 am
There is definitely something going wrong.
My previous post should all be on separate lines with the text between the images - not after the image.

Barry.

I've gotten into the habit of double line returning before and after images, quotes and code.



Ling.