The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Modelling and drafting in ARCHICAD. (Example: How can I model a Roof soffit/fascia?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

#289393
In the 22 user guide there is a "Small Improvement" noted ...

• Selection of overhead elements in Floor Plan now omit their surface detection, to give priority
to selection of uncut elements. Select overhead elements by their outline.

This is fine, but am I not understanding something or is there an inconsistency happening here?

If I have any roof (single or multi plane) and the Floor Plan Display is set to 'Projected with Overhead' or 'Overhead All', then I can not select the surface of that roof - must select it by the edge.
This is consistent with the above statement.

roof_select_1.jpg

If I have a single plane roof set as 'Outlines only', I still can not select any surface.
Again consistent with the above statement - although technically it is not set as 'Overhead'.

roof_select_2.jpg

Now when I have a multi-plane roof set as 'Outlines only', I can select the surface.

roof_select_3.jpg

So which one is inconsistent?
I would like the single planes when set as 'Outlines only' to be selectable by their surface, because as I said technically they are not set to overhead.

Or am I just missing something not quite so obvious to me?

Barry.
#289395
Also the physical height of the roof seems to have no impact on the surface selection.
Even if it is entirely below the Floor Plan Cut Plane height, a single roof plane will not select by surface.

I just also noticed adding a cover fill to the single planes will allow surface selection - even an empty fill will do.
But the multi-plane roofs do not need a cover fill at all.
Another inconsistency? - but a solution for a work-around.

Barry.
#289600
Hi,

I can not reproduce the same behaviour here from the INT template. When I set it to outlines only, it will always have a fill for me to select, and if it is set to overhead all, then it will not - regardless of whether it is a single or multi-plane roof.

Can you send me the file in which you experienced otherwise?
I am on v22 4023 (latest update), maybe that is making a difference?

Thanks,
#289623
Thanks for the offer Daniel, but I just figured out what the problem is.
Legacy mode.

legacy_roof.jpg

We have the legacy mode on for single roof planes (which we still use a lot).
A setting we made in out template when we switched to version 15.
There was a reason for it at the time but I can't remember now (double edge lines for non vertical edges maybe?).
Just one of those settings that has always been on - just because.

I will have to look into it again and see if we can't switch it off now.

Barry.
#289632
Barry, I think the legacy setting has to do with how skylights are shown.
Yes it will affect the skylights but as I thought, if the roof edges are not perpendicular and the bottom surface is larger than the top surface, then you will see a double lined on each edge.
This is because when legacy mode is off, the plan for roofs is a top down view and what you see is what you get.

Barry.
Attachments
legacy_roof_2.jpg