The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Modeling and drafting in Archicad. (Example: How can I model a Roof soffit/fascia?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

User avatar
By Hassanen
#112652
I deleted an Xref without choosing to delete its attributes. How do I now delete all the Xref layers?
Attachments
LAYERS.jpg
User avatar
By Laura Yanoviak
#112659
Either select them and delete with the Layer Settings dialog (as you have shown), or use the Attribute Manager.
User avatar
By Hassanen
#112661
The delete button in the layer dialogue is grayed out.
And they don’t show in the attributes manager
Attachments
LAYERS2.jpg
User avatar
By Dennis Lee
#112662
Reimport the same xref file, then remove xref with the delete attributes option.
User avatar
By Laura Yanoviak
#112663
Has this project been Teamworked?

Regardless, I've had this happen (where the layers show up in the Layer Settings, but not in the AM) -- they don't seem to impact anything, it's just annoying that they don't go away.

If the project is Teamworked, try deleting your teamwork preference files. If not, try re-attaching the Xref, and then detaching again (this time deleting attributes) -- this might just work in the twisted-AC-logic sort-of-way.
User avatar
By Josh Cuthbertson
#187571
Also, notice when you open your layer manager the option above the "New" button. You have the option to hide xref layers too.
By sarahric
#202207
I would like to reopen this issue.
I have the same problem and have followed the steps noted.
Firstly I have bound the inital xref to keep the information, then attach the same xref. When it's done, it adds a second set of un-editable layers.
Then I detach the xref, the previously bound xref disappears from the screen, but both sets of layers remain...
User avatar
By ejrolon
#202212
I think that it was mentioned on another post, the trick to remove X-Ref layers is to delete them using Attribute Manager instead of the Layers.

I think it is a bug that only happens when the file was "Teamworked" at some point.
User avatar
By Josh Cuthbertson
#202216
Though it is an incredible pain, our work around is to open a "fresh" Archicad and ad the xref file. Then we take the layers and sort them into our office standard and then copy the objects over.

It seems to help us keep the models quite clean.
By sarahric
#202239
i don't think the file was "teamworked". does this happen just because another person opens the file?

Have tried deleting from the attributes manager but does not work.