The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Modelling and drafting in ARCHICAD. (Example: How can I model a Roof soffit/fascia?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

#288044
Now that we have modifiers in complex profiles in version 22, I am starting to set up some more useful profiles.
However I have come across a problem that I am hoping may be controlled by a setting I am missing.
Otherwise it is a rather obvious bug that I can't believe ahas not been noticed.

I have a complex profile wall that has a wider base with a thinner wall above (my example here is exaggerated to show it clearer).
In 3D, the widow reveal offset follows the Opening Reference Line position in the profile.
This is perfect.

However in plan the wall must be shown as 'Projected with Overhead' (rather than 'Symbolic') which means the Floor Plan Cut Plane height comes into play.
If the FPCP is set to a height lower that the recessed wall, then the windows all offset from the face of that wall - this is OK if my Opening Reference Line is at this position.
But as soon as the FPCP height is higher than the bottom brickwork, the windows in plan all offset from the recessed brickwork and not where the Opening Reference Line position is (which is the front of the lower wall.

The attached image will show it better.
Am I missing a setting somewhere so the plan view uses the Opening Reference Line as set in the complex profile?
Isn't this what should be happening?
Shouldn't the 2D view be matching the 3D view.

This was tested with default Graphisoft template and standard window in version 22.
I also tested in version 18 and it was the same.


Barry.
Attachments
open_ref_problem.jpg
#288046
I just realised that I have to set the windows to 'Projected with Overhead' as well (rather than 'Symbolic').

However that is still a problem.
I want to keep using the symbolic view of my windows.

Barry.
#288050
No, unfortunately it doesn't matter what I set the anchor to.
That doesn't affect the 2D or 3D position.

Barry.
#293049
When I switch my windows from symbolic to projected to avoid this bug the separator lines from my complex profile now run right through my window. To see if I could fix this with a different window projection I started selecting the other types. While this didn't help with the problem, when I selected symbolic again the window is now correct in 2d and 3d. So it appears just switching between symbolic to projected and back again fixes the problem.
I haven't tested to see if this will survive through an open close cycle but I'll update if it doesn't.
Attachments
Window Plan.png
#293123
After 3 years they still haven't fixed it (it works correctly in Archicad 18 and before)

This Problem has been around since Archicad 19
IN 3D The origin for the window is set to the widest part of of the wall
IN PLAN The origin for the wall is at the cut plane thickness not the anchor point location.
IN CODE The value of "Wall_Thickness" is still the anchor point

so you can't even code your way out of it.

This use to work correctly (thickness, etc at the anchor point of the window)

It is surprising they have not fixed it yet.

i hope graphisoft is listening....