The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Modeling and drafting in Archicad. (Example: How can I model a Roof soffit/fascia?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy

By 4hotshoes
#305725
It was working fine for this project a week ago. I have the same computer, I have not changed any keyboard shortcuts, I have restarted Archicad, but none of the keys will now function during navigation, not even the esc key, none! The mouse will let me look around and click to cancel. The keyboard works fine when not using Explore Mode. Any ideas what might be happening?
User avatar
By Barry Kelly
#305728
If the ESC key is not working it could be something more serious, like another program running in the back ground that is hi-jacking the keys.

Otherwise try pressing the F8 key to toggle on/ff the parallel view.
One mode will only allow you to rotate the model with the mouse and the movement keys will be disabled.
The other mode allows you to explore as you would expect to.

Barry.
By 4hotshoes
#305752
Barry Kelly wrote: Mon Jan 13, 2020 2:58 am If the ESC key is not working it could be something more serious, like another program running in the back ground that is hi-jacking the keys.

Otherwise try pressing the F8 key to toggle on/ff the parallel view.
One mode will only allow you to rotate the model with the mouse and the movement keys will be disabled.
The other mode allows you to explore as you would expect to.

Barry.
The F8 key will not do anything in any mode. What is the official command assigned to F8? I will look it up in the command list to see how I can try to activate it. But the 3D Explore mode locks out all keyboard keys or simply disables my keyboard.
User avatar
By Barry Kelly
#305761
Sorry, I was thinking you were exploring in BIMx viewer for some reason.
Not the explore mode in Archicad.

There are other posts about Explore mode not working properly, but mainly to do with the view scrolling (moving) by itself.
It seems the problem with this has to do with Archicad being on a second monitor and not the main one.

I am sure there are posts here about the keys not working.
If I find them I will let you know.

Barry.
User avatar
By Barry Kelly
#305762
Seems to be a bit of a MAC issue?

I found these post that seem to say restarting works but it comes back.
Updating the OS seems to be the solution.

viewtopic.php?f=20&t=50351&hilit=explor ... 10#p267031

viewtopic.php?f=13&t=51787&p=252159&hil ... ys#p254855


This one is more for all shortcuts but does mention Explore mode.
It seems there could be a few problems/solutions.
Language settings.
OS update.
Re-apply Work Environment.

viewtopic.php?f=20&t=5773


Maybe it will be best to contact you local Archicad support before playing around with updates.


Barry.
By 4hotshoes
#316130
Barry Kelly wrote: Tue Jan 14, 2020 1:57 am Seems to be a bit of a MAC issue?

I found these post that seem to say restarting works but it comes back.
Updating the OS seems to be the solution.

viewtopic.php?f=20&t=50351&hilit=explor ... 10#p267031

viewtopic.php?f=13&t=51787&p=252159&hil ... ys#p254855


This one is more for all shortcuts but does mention Explore mode.
It seems there could be a few problems/solutions.
Language settings.
OS update.
Re-apply Work Environment.

viewtopic.php?f=20&t=5773


Maybe it will be best to contact you local Archicad support before playing around with updates.


Barry.
The problem of not having the keys working in Explorer mode to move around AND the Magic Wand tool does not work has happened again.

I can't remember how I fixed it before and the links provided above do not give a solution. I am on a MacBook Pro and just upgraded the OS to Catalina 10.15.6. It has something to do with the OS upgrade most likely. I remember that it took a long time to find the solution, but it was really simple.I wish I had written it down here so I can read it again. :cry:
By Thomas Allan Palmer
#321427
All, This is happening in our office to some machines as well.

MacOS Mojave 10.14.6 (but only some machines)

Resetting Work environment doesn't work
Language settings have no effect.

Tom Palmer
ArchiCAD 23 and 24 (USA)
imac. iMac (Retina 5K, 27-inch, 2019)
User avatar
By jakubc7
#321430
I am guessing that your magic wand / space bar doesn't work either? I had the same issue when working in another office. Here is another topic about the issue that haven't yet been mentioned:
https://archicad-talk.graphisoft.com/vi ... 37#p265937

All the MAC computers (probably 3 machine) had the issue and the one PC was just fine. We could never resolve it - and I tried! I wouldn't be able to tolerate it but left shortly after however as far as I know they still have the issue a few years on.

If I recall correctly it stated happening after a server update (although it may have been unrelated?)
Sorry I can't provide any actual help :(
By 4hotshoes
#321460
The problem crops up randomly, bet seems to correct itself if I shut down Archicad each night. The longer I leave Archicad open, the more likely it will reoccur.
User avatar
By mnguyen
#321633
Dear All,

Thank you very much for your report and I am very sorry about the issue!

Although I cannot offer a solution that works for every case, I will try to give what we know so far when similar situations happen.

- The problem is in Archicad: sometimes a hotkey/shortcut is assigned with another one. Usually, by resetting Work Environment or performing Preferences Cleaning the issue will be fixed.

- The problem comes from other software: other software might also take over the keyboard control. My suggestion is to try using shortcuts with various programs to see if it works.

- The problem comes from OS update: sometimes an OS update may mess up the input. A restart should help in this case.

- The problem is hardware-related: simply try with another mouse/keyboard to see if it functions correctly.

I am very sorry that I cannot give a more precise answer based on the given information, but please let me know if it helps!

Best regards,
Minh