The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Discussions about using GRAPHISOFT's tools (API DevKit) for independent software developers

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy, rmasaki, MOREH Tamas, Akos Somorjai, Ed Brown, Mihály Palenik, Tibor Lorántfy

#312152
I have recently downloaded Archicad 23 (23.0.0.3003) and tried to install the Experimental Python add-on but in the Add-in manager, I got the message that the Add-on was outdated (see screenshot below). I thought the Add-in would work with Archicad 23? Or does it only run on a specific sub-version of 23?

Many thanks in advance!
python-error.PNG
#312153
mnky wrote:
Wed Jun 17, 2020 10:48 am
I have recently downloaded Archicad 23 (23.0.0.3003) and tried to install the Experimental Python add-on but in the Add-in manager, I got the message that the Add-on was outdated (see screenshot below). I thought the Add-in would work with Archicad 23? Or does it only run on a specific sub-version of 23?

Many thanks in advance!

python-error.PNG
Hi, I had a similar problem.
Try adding the extension via the add-in Manager in a path other than the ARCHICAD folder.
#312325
Hi All,

To those with Python add-on outdated issue, thank you for sharing the issue with us!

I encounter a similar symptom as you described. It turned out that I had Python 3.8.3 installed on my machine. The guide for the Experimental Python Add-On for ARCHICAD23 stated that "Python 3.7 must be installed to your machine.".

Once I removed Python 3.8.3 and installed Python 3.7.3, the add-on is loaded correctly. Please download Python 3.7.3 here
Windows: https://www.python.org/ftp/python/3.7.3 ... -amd64.exe
macOS: https://www.python.org/ftp/python/3.7.3 ... sx10.9.pkg

Let me know how it goes for you!

Best regards,
Minh
  • 1
  • 4
  • 5
  • 6
  • 7
  • 8