The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Discussions about using GRAPHISOFT's tools (API DevKit) for independent software developers

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy, MOREH Tamas, Akos Somorjai, Ed Brown, Mihály Palenik, Tibor Lorántfy, rmasaki

User avatar
By ReignBough
#301738
I got the following errors.

1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(65): error C3646: '_THROW1': unknown override specifier
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(65): warning C4595: 'operator new': non-member operator new or delete functions may not be declared inline
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(65): note: to simplify migration, consider the temporary use of /Wv:18 flag with the version of the compiler with which you used to build without warnings
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(65): error C2059: syntax error: '('
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(66): error C2143: syntax error: missing ';' before '{'
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(66): error C2447: '{': missing function header (old-style formal list?)
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(74): error C2601: 'operator delete': local function definitions are illegal
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(79): error C3646: '_THROW1': unknown override specifier
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(79): error C2059: syntax error: '('
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(79): error C2059: syntax error: ')'
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(80): error C2143: syntax error: missing ';' before '{'
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(80): error C2447: '{': missing function header (old-style formal list?)
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(88): error C2601: 'operator delete[]': local function definitions are illegal
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(94): error C2601: 'operator new': local function definitions are illegal
1>...\api development kit 20.3012\support\modules\gsroot\GSNew.hpp(100): fatal error C1903: unable to recover from previous error(s); stopping compilation

What might be causing it?

(ARCHICAD 20 on VisualStudio 2017)
#301744
ARCHICAD 20 uses the Visual Studio 2010 toolset for building Add-On projects.
Unfortunately VS 2017 and VS 2019 both won't allow to install VS 2010 toolset, so you won't be able to build AC 20 Add-Ons with VS 2017 or VS 2019, you have to install VS 2010 itself.