The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Discussions about using GRAPHISOFT's tools (API DevKit) for independent software developers

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy, MOREH Tamas, Akos Somorjai, Ed Brown, Mihály Palenik, Tibor Lorántfy, rmasaki

By Math2843
#302058
Hey Everyone!
Been trying to resolve an issue, I have a working build of an ARCHICAD 22 AddOn, it will however not load on ARCHICAD 23, I get the "The file is an outdated Add-On that cannot be used with this ARCHICAD version." error. I have been trying to discover how to update the AddOn to support ARCHICAD 23 to no avail, I have the source code for the AddOn available what should I change in order to build the AddOn for ARCHICAD 23?
#302099
There are at least 3 things you will need to address:
1) On Windows start using Visual Studio 2017 (or 2019 with the 2017 toolset). On macOS continue using Xcode but bump the deployment target to 10.12

2) Swap in the AC23 dev-kit to replace AC22. This may mean linking against different libraries and/or specifying different include paths.

3) Update your source code to address changes to the API or target platform requirements.
User avatar
By Tibor Lorántfy
#302101
Math2843 wrote:
Wed Sep 25, 2019 1:44 pm
I have a working build of an ARCHICAD 22 AddOn, it will however not load on ARCHICAD 23
It's normal, because each AddOn is compatible with only one ARCHICAD main version.
AddOns must be rebuilt for each ARCHICAD versions.
Follow Ralph's instructions and don't afraid to ask help here ;) We will help!