The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Plan, Section, Elevation, Schedule, Layouting...

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

What's your opinion about this wish?

Essential (5)
12
75%
Important (4)
4
25%
Average (3)
No votes
0%
Not important (2)
No votes
0%
Not needed (1)
No votes
0%
#252447
Now you need to draw a Marquee around your generated 3D and press CTRL+C to copy to the Clipboard. This is when the Copy Dialog comes up which lets you set exactly how you want to copy those lines and fills.
Select the options you see in the attached image. The most important ones are "Scaled Drawing", and "Overlapping Polygons". The Overlapping Polygons options will copy all Shadow polygons generated by the program in 3D to the clipboard.
Attachments
SectionShadowsFromWallsBehind3.png
#252448
Now you can paste this into your Elevation. Only the Shadow polygons will be pasted. In the below image I pasted the shadow polygons and also moved them 8000 mm up so I can take a look at them and sort out the ones I need.
This is the good thing about the "Overlapping Polygons" setting: it will copy and paste all shadow polygons. Apparently those shadow polygons that were not visible in the 3D Window were generated by ARCHICAD, but were hidden behind other Walls. This is how to get their geometry.
Attachments
SectionShadowsFromWallsBehind4.png
SectionShadowsFromWallsBehind4.png (3.84 KiB) Viewed 4167 times
Last edited by LaszloNagy on Tue Feb 23, 2016 3:59 pm, edited 1 time in total.
#252449
In this example I needed only the one shadow that is lighter than the others. I can move that one back to its proper position in the Elevation, maybe bring it forward in the Display order and it is done. I can just delete the other pasted shadow polygons that I don't need.

The reason some of the shadow polygons were different in color was because they were cast on different surfaces. If you change the Surfaces prior to generating the 3D with shadows, then after copy-paste, it will probably be easier to select using Find & Select only the polygons you need. This of course applies only if it is tedious to select the needed polygons manually because of there are many complex and overlapping pasted shadow polygons.

I think this is easier to do than to explain so it should not take more than 2 minutes.

Unfortunately, if the geometry behind the Section line changes, you will have to redo this.
It may be a good idea to place these pasted shadow polygons on a separate layer for easier management.
Attachments
SectionShadowsFromWallsBehind5.png
SectionShadowsFromWallsBehind5.png (2.44 KiB) Viewed 4166 times
#284810
I'm currently facing the same issue with council requesting sun shadows on neighbouring elevations. I followed your method, however, couldn't paste the hidden overlapping shadows. It only pasted the visible shadows in the parallel view. Any update on this? Looks like this may have been working in AC20 and may have been phased out in AC21?? Any help would be much-appreciated Thanks!
#299244
sbyrnes wrote:
Thu Aug 09, 2018 3:58 am
I'm currently facing the same issue with council requesting sun shadows on neighbouring elevations. I followed your method, however, couldn't paste the hidden overlapping shadows. It only pasted the visible shadows in the parallel view. Any update on this? Looks like this may have been working in AC20 and may have been phased out in AC21?? Any help would be much-appreciated Thanks!
I'm experiencing the same thing.

We recently upgraded from AC19 to AC22 and now in 22 it does not work any more - it only pastes the visible shadows. I went back and tested the method in 19 to make sure I wasn't going crazy and it worked perfectly with all overlapping fills from hidden elements in different colours as usual pasted into the elevation view.

This is a really important part of most development applications these days and this technique has been an office standard that no longer works.
#300107
Hi,

I looked into this issue, and apparently the "Overlapping Polygons" option stopped working in ARCHICAD 21, and they produce the same result as "Calculate Split Polygons". I let the Developers know about this, hopefully they will be able to fix it soon (task #266367 in our system).

As a workaround I would try something like what Rob suggested. If you take the elements in the foreground in the 3D Vectorial window, override them all to 'Glass - Clear Fast' (using any method you'd like: e.g. Graphic Override Rules), and then copy the shadow polygons like that, you can get the entire covered shadow.
I tried it this way, it seems to be working like this.

Regards,