The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Producing imagery with ARCHICAD or 3rd party products; Surfaces; Lighting; Cameras; Artlantis/Cinema 4D/Maxwell etc.

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

By aze13
#289009
Export to C4d
Hello

We worked with this great DIN 3D addons that worked very well for many years
We had a continuous workflow
But today impossible to find a solution
We are told about BIM from ........
I am not a programmer but it must not be very complicated to create this kind of plugin
We were exporting our scene, the textures '' vray '', and the updates worked it kept the textures '' vray "but now your solutions do not work ....

I am very angry because we are 10 people at the agencies who have this problem at the price that costs archicad 22 and c4d: evil:
I'm sorry for this bad mood but we're losing a lot of time
Thank you if you have a solution
User avatar
By prot158
#289067
Hi. I’ve been also working with din3D for years, but now, i’ve upgraded to archicad 22 so it doesn’t work anymore. I’ve tried to find a way to deal with graphisoft exporter. It’s a bit longer but it kind of do the job:

The trick is to merge the .c4d exported files into a first file and then import it into a second file as a xref.

1. Into a new c4d document, merge the exported .c4d file. (I just keep geometry and material) and then combine (Pipeline>Combine)
(1bis) for an update, delete everything under de “Master” null and then merge+combine

2. File cleaning: i use a free script to rename polygons as their parent null. (in the object manager click the top right “eye” to see the filters - under objects, right click Polygon to select all)
Image
Then use the script A_simple-object -renamer to rename them all (use the “after parent” option)
Then I fold all, select all the nulls et do a “delete without children”.
My file is like this now:
Image

3. In a new file, import it as a “xref”
- Make sure you have “show object” and “Loaded” checked and “generator” unchecked.
- under “xref” options:
reference tab: name space > none ; auto match > unchecked
import tab : check all
modify: check all
(This step as to be done only once, the first time, after you just have to reload the xref)

4. You can now modify or replace materials. If you reload the xref, materials remain.

That the best I can do for now
By aze13
#289104
thank you for your help
I will look at it
But I do not know if it works for me
As I apply textures 'vray' and on the updates the textures 'vray' disappear
User avatar
By Carstenem
#289139
There is a good solution I used for years but not sure if it works with Cinema4D. Have a look if this could be helpful.

http://www.scriptspot.com/3ds-max/scrip ... nk-manager
User avatar
By prot158
#289183
Carstenem wrote:
Fri Nov 23, 2018 12:55 am
There is a good solution I used for years but not sure if it works with Cinema4D. Have a look if this could be helpful.
http://www.scriptspot.com/3ds-max/scrip ... nk-manager
No. It’s just for 3DS :(

BTW.
In order to simplify the process, i’ve written a script to automate a few steps. It cleans up filenames too.
So, now you work like that:

1. Open the exported .c4d file. Run my script. Save and close.
2. Import the xref as before, or update it.

It’s a WIP, feedback welcome
(3.8 KiB) Downloaded 38 times