The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Discussion of non-graphical data: Properties, Property Expressions, Classifications, Interactive Schedules

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

Hi all,

it seems that the Schedule of Surfaces no longer will let me use any created parameter.

If the parameter is used to filter :
Nothing will be find and describe by the schedule

If the parameter is used as part of the schedule ("describe") :
Elements will be found but the parameter will be noted as "--" in the schedule

It did work perfectly in AC22 ... Any idea why or how to make to fix that ?
What is this "Services" parameter that you are trying to schedule? Is this an element Property you created in the Property Manager Dialog? In my Archicad 24, I see that there is no such parameter available by default.
All I can see from your screenshot is that "Services" is a Text type parameter.
And yes, from your screenshots I can see that it returns a value when used in an Element Schedule, but no value when it is used in a Surface Schedule.
KaitenPower wrote:
Tue Oct 20, 2020 5:16 pm
The "Services" parameters is Text Parameter I created my self. (It can be used for all kind of elements).

I do a lot of Offices, and i need to specify the "services" for a lot of stuff, such as zones, furnitures and partition

I can confirm (tested in 24) that a string property returns no value when used in a surface schedule.
I am not sure why as all other (at least lengths and number properties) seem to work fine.

Hi all,

Thank you very much for your reports and I am very sorry about the issue!

This is a known defect in our database (please refer to it as DEF-1835). From AC23, the Surface schedule cannot handled string properties correctly, they will be shown as "---".

The workaround here is to use Element schedules instead, but I can see that in some cases, this won't be possible. I hope that we will be able to correct it in the near future!

Thank you for your understanding, and once again I am very sorry for the inconvenience!

Best regards,