The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Discussion of non-graphical data: Properties, Property Expressions, Classifications, Interactive Schedules

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, Gordana Radonic, nbalogh, gkmethy, mnguyen

By LM19
#328741
As you can see, I have the box ticked to sort by the keynote number, but it seems that double digit numbers fall between 7 and 9 for some reason. (UPDATE: I added note 6 and it falls between 11 and 9, so the pattern is not applicable) What am I missing? These are associated keynotes.
Also, is there any way to drag rows around?
Any way to set the vertical text alignment of the cells to top alignment?
I've been working with the keynotes and schedules for about a day now, and they look terrible and I can't see any good ways to adjust their appearance. Overall annotation settings seem to be severely lacking in AC24.
Attachments
Screen Shot 2021-06-23 at 10.18.18 AM.png
Screen Shot 2021-06-23 at 10.18.18 AM.png (641.63 KiB) Viewed 160 times
#328749
It looks to me that you have a space before the 4 & 7, but not the 9.
This will affect the listing order.
Spaces can be hard to see so I prefer to use 04, & 07.


Barry.
User avatar
By LaszloNagy
#328796
Yes, these leading spaces or leading zeros are required when those numbers are actually "text". I suppose those are Properties with the "String" ("Text") Data Type.
If they were numbers, they would be correctly sorted.
I just checked and it seems to me that other Property Data Types, such as Length, Area, Volume, are not sorted correctly either.
By LM19
#328831
Barry Kelly wrote: Thu Jun 24, 2021 2:10 am It looks to me that you have a space before the 4 & 7, but not the 9.
This will affect the listing order.
Spaces can be hard to see so I prefer to use 04, & 07.


Barry.
They did, but that didn't fix the whole list, and not every number was editable. Is there no way to drag the rows around? What about the formatting for individual cells?
#328871
No, you can't just move rows.
Just change them from ascending to descending order (or none) in the scheme settings.

Formatting only affects the font, size, justification, etc.
Not the actual content - that comes from the elements you are scheduling.
You need to edit the 'keynote #' value in the object directly, or you may be able to select and edit it in the schedule.

You need all of the 'keynote #' values to follow the same format.

01
02
.....
08
09
10
11
12

or
001
002
.....
009
010
011
.....
099
100
101

You can use spaces (or underscores) instead of leading zeroes, they are just harder to see.


Barry.