The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Discussions about managing Archicad in architectural practices (Project Setup, Templates, Attributes, Migration, Compatibility with Previous Versions, Preferences/Work Environment, User/Project/Application Administration/Management etc.)

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, Gordana Radonic, nbalogh, gkmethy, mnguyen

#330289
May I ask - only I have troubles with placing pipes objects ? In my case even 3D preview page of object shows error. I see only their image. Same for tees, elbows etc.
I didn't look through everything, but others seems to work fine.

Thanks Podolsky, for sharing.
Looks like your skill level of ArchiCAD and GDL is almost unreachable.
#330292
A. Smith wrote: Wed Jul 21, 2021 3:08 pm May I ask - only I have troubles with placing pipes objects ? In my case even 3D preview page of object shows error. I see only their image. Same for tees, elbows etc.
I didn't look through everything, but others seems to work fine.

Thanks Podolsky, for sharing.
Looks like your skill level of ArchiCAD and GDL is almost unreachable.
All MEP objects must work, as I designed and used them on my projects. There are two reasons why objects can give error - when data files in embedded library are missing (they embedded by default into template file) and when ArchiCAD MEP library is not connected, because my objects - it's a modification of standard objects and part of object functionality is requested from MEP macro.

They also can have some small errors in user interface on Windows - some text might not shown correctly. It happened because I wrote everything on Mac and didn't test on Windows.

Although each element was used on running projects - still some minor bugs can be expected. But that can be fixed by anyone who knows GDL - and this why I opened source of the library, as unfortunately I cannot push this development further.
#330295
Podolsky wrote: Wed Jul 21, 2021 3:32 pm All MEP objects must work, as I designed and used them on my projects. There are two reasons why objects can give error - when data files in embedded library are missing (they embedded by default into template file) and when ArchiCAD MEP library is not connected, because my objects - it's a modification of standard objects and part of object functionality is requested from MEP macro.
You're right - MEP default library wasn't embedded ... (facepalm)
#330775
Podolsky wrote: Sat Jul 17, 2021 4:21 pm Hello all. Seems that I cannot continue this development because of health issues (serious spine problems). Anyone who is willing to pick up my libraries, modify or do anything about it - feel free.
The password to the scripts 'neilsmith'

Cheers
Thanks for the template! Get well. Greetings from Kyrgyzstan!