The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Discussions about managing ARCHICAD in architectural practices (Project Setup, Templates, Attributes, Migration, Compatibility with Previous Versions, Preferences/Work Environment, User/Project/Application Administration/Management etc.)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

User avatar
By dhnguyen
#278154
I need a tutorial on pen setting.

Coming from AutoCAD background, I'm used to having a ctb file with specific layer, lineweight and thickness that's associated with it.
Here in ArchiCAD I'm lost. I have been googling and reading discussions here and there but I still don't understand it.

For example, please see attached. In model space I chose a color and gave it a pen setting thickness (1mm).
When I go to the layout book, it does not look like it's 1mm thick, what is the problem?

Also, not to mention that the dashed lines around those rectangular strips show up as solid in layout, unless I hide my fills (hatches).
model space.PNG
layout book.PNG
User avatar
By mikas
#278155
I don't know what is a ctb file. But I guess it's something of an equivalent like in ArchiCAD would be a saved "View". A saved view has got all the necessary attributes associated with the model for it to output it as it's wanted to be seen. They will be pseserved all along the project allthough you manipulate every other aspect of the model. You can give as many different groups of different attributes as you want to.

One thing to remember; You have to specify the attributes particularly for each view. That means you have to give a name to every attribute group you are going to use with views, and then use the attr-groups for every view. Don't leave any of them unnamed.

Give a name to pen color and wirht group.
Give a name to level group.
Give a name to graphic overrides (earlier model views or something like that)
..etc.

Then select all the given and named attribute groups, and save a view.
Then use that view in a layout.

Later on you can go and change the named attribute groups if you want to. Such as pen widths or colors. But you have to remember to save the attributes with the same group name that was used saving the view the first time. Or you have to specify another saved and named attribute group to a view.

You can change the attributes later at will, and save them again to a view. Or copy a group and change it, and assign that new attr-group to some other view.

OBS: If you don't use a view in a layout, you will eventually be lost and wondering what's happening. Use only saved views with named attribute groups in every layout, and you are ok.

I do think the user interface is not the best possible in ArchiCAD with all this, and it's not even consistent all the time with every feature. But once you get it, you will get desired results and you will deliver fast.

Just be patient, it's probably a little bit a different beast than your former program.
User avatar
By Lingwisyer
#278165
AutoCADs .ctb files would be similar to ArchiCADs Pen & Colours. Though unlike AutoCAD, each drawing placed in a layout can have a different Pen & Colours setting. This can be edited in the Drawing Settings under Pen Sets. These settings only affect the line weights and colours. Line types are controlled separately and vary based on how an object is viewed. They can usually be modified within each objects settings.


Ling.
User avatar
By Richard Morrison
#278204
The issue could be as simple as clicking on the "Show lineweights" button. Or, maybe there is a graphic override that is changing everything. To the OP, it would helpful to add your version of AC to your signature. Prior to AC20, we used different pen sets and Model View options to control line weights and line types. Now, Graphic Overrides are king.
User avatar
By dhnguyen
#278232
Thank you all for the responses. I'm using ArchiCAD 16.

I still don't understand why my lineweight doesn't show up the way i wanted it to be. If i set a color to 1mm or 3mm thick, it should show up as that thick when I print it to PDF. And I did select the right profile when I print to PDF, however, it doesn't look that thick.
User avatar
By Barry Kelly
#278248
If you are sure you are using the same penset for the drawings in you layout then check the 'Document Settings' of the PDF in your publisher set.
In there is an option to print as 'Hairline'.
This might be on overriding your pen thicknesses.

Barry.
Attachments
PDF_hairline.jpg
User avatar
By gpowless
#278346
Make sure that you are using the same pen set for both drawing & layouts. You can change the layout pen weights on the fly.