The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Discussions about managing ARCHICAD in architectural practices (Project Setup, Templates, Attributes, Migration, Compatibility with Previous Versions, Preferences/Work Environment, User/Project/Application Administration/Management etc.)

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

User avatar
By Mats_Knutsson
#288543
Hi,
Is there any way to fix which icon is displayed for pln files?
If you install new versions of AC, all pln files automatically get the icon corresponding to the latest version of the archive installed. (not the latest AC version but last installed)
Similarly, if you uninstall an old version of AC, all pln files lose their icon and appear as a generic file.
It still works to open all files as it should. But the icon appears wrong!
Mats
User avatar
By Barry Kelly
#288565
If you associate the Archicad program with the .PLN file type, then it should show the correct icon.
No idea with Macs, but in Windows right click on a .PLN file and 'Open With'.
Then choose 'Choose another app" and browse for the Archicad 22 (or other version) program (.exe) file.
This should create the association and set the file icon.
You may need to restart your machine.

file_icon_22.jpg

Also we used to be able to set any icon in the FILE menu > File Info > Project Preview ...
Here we could paste any image we wanted and we would see that for each file.

file_icon_21.jpg
file_icon_21.jpg (26.93 KiB) Viewed 2256 times

So you can have a different icon for every file if you want.
I just use a number for the version but it could be a 3D image of the project as well (although it would be very small).
So you could get this ...

file_icons_1.jpg
file_icons_1.jpg (37.16 KiB) Viewed 2256 times

But this seems to be broken in 22
I can't get it to work.
It used to be a case of going to ... C:\Program Files\Graphisoft\ARCHICAD 22\GRAPHISOFT Shell Extension
And then running the 'Register.bat' file.
Restart the machine and the preview icon appeared for all .PLN files.
The best I can get is the blue Archicad arch now.

Barry.
User avatar
By dkovacs
#292907
Hello,

Thanks for the extensive explanation about how to associate file types Barry.
On macOS this works similarly: you have to right click on a PLN file, select Get Info, and in the appearing window, under "Open With" you will have the option to select the default application. Select the correct ARCHICAD version here, and click the "Change All..." button to apply it to PLN files in general (not just the selected instance). Also, Project Preview Pictures automatically appear on macOS (if the file type is correctly associated with ARCHICAD of course).

I added it to our list of issues that displaying the project preview image as the icon sometimes does not work with ARCHICAD 22 files. The bat definition used for this hasn't changed for years so we are not quite sure why this is (maybe something changed in Windows), but we are looking into it (issue #257594).

In the meantime I got the following suggestions that might help this problem:
  • Right click on the bat file, and select "run as Administrator. For a few years now command prompt has an Administrator and a non-administrator mode, and it can make all the difference (so for certain commands, you have to start command prompt as an administrator to work). After running this, restart the computer.
  • Modify the bat files a bit and Run them again (as Administrator of course)
    1. Right-click the bat file and choose 'Edit'
    2. Add a new line between the 2 existing ones and enter this into it:
      cd %~dp0
    3. Save the bat file, run it again (as Admin), and restart the computer.
  • Register the Shell Extension through Command Prompt
    1. Run Command Prompt As Administrator
    2. Run the following command (with the path of your installed ARCHICAD of course):
      regsvr32 /s "C:\Program Files\GRAPHISOFT\ARCHICAD 22\GSShellX64.dll"
    3. Restart the computer
  • If it is still not working, try reinstalling ARCHICAD 22
When we were testing things here, after doing all these steps, it started working again. Hope it will help you as well.

Regards,
Attachments
get info.png
User avatar
By agroni
#293869
:shock: :shock: WOW! Barry...You have 8 versions of Archicad on your computer! :shock: :shock:
How many of the do you use :wink:
User avatar
By Barry Kelly
#293919
agroni wrote:
Fri Feb 01, 2019 9:14 pm
:shock: :shock: WOW! Barry...You have 8 versions of Archicad on your computer! :shock: :shock:
How many of the do you use :wink:
I actually have more than that, as I also have AUS, INT and USA versions just to see the differences (library objects mainly), not to mention different builds, preview and beta versions when testing.

I actually use only AUS versions 18, 20 and 22.
I create all of my library objects in 18 so that is compatible with the oldest version we use.
I was doing this in 15 until about 6 months ago when we decided we will no longer support anything older than 18, to force all of our offices to upgrade.
We are in the throws of converting over to 22, but with hundreds if not thousands of standard plans and current jobs, it is not a quick process.

Barry.
User avatar
By Barry Kelly
#293920
While I am back in this topic, I have tried all of the suggestions made by Daniel, but I still only can get the blue arch symbol for the PLN files.
I know it is possible to have custom icons because while installing 22 on other machines around the office I can still see them.
There is obviously a setting somewhere (I assume in Windows) that is stopping this on my machine (and some others).
The problem is all of our office machines may be set up slightly differently to each other and I don't have direct access to these machines to play with settings.
Some may be even still on Windows 7 and I think these are OK but I am sure I have seen other Windows 10 machines where the custom icons work as well.

It is not a big deal, just nice to have.

Barry.