The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Sharing a project for a team, accessing projects remotely. Setup of BIMcloud/Users/Roles, Working/Messaging in Teamwork (Example: What are the firewall settings for the BIMcloud to make it accessible over the Internet?)

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy, Istvan Moharos, Marton Kiss

User avatar
By Steven Dumont
#146586
I have posted this before. Well, it's still happening and no one can give me an answer to this problem so I decided to try again...

While in teamwork, I go to change my workspace. It chugs along for a second and then says

"Can't read the teamwork project"

I say "OK"

Then it says

"Project (project name) not found or stored name doesn't match. Please find the project manually."

So I click "OK"

It then brings me to a browser window showing the exact location of the file I'm working on. I click on the file. Then I get

"Can't read the teamwork project"

I can't do anything then except click "Cancel"

It then says "Cannot read teamwork administration data"

I then am back to where I started. For some reason if another team member sends and receives changes then I immediately change my workspace, I can do it. This is a major distraction and effects productivity. Can anyone help me?
By Charlee
#146640
That's a new one.
Are you using 2 different versions of ArchiCAD?
ie. you on 10 and your workmate on 11?
All have same patches installed?
And is anyone updating drawings in a linked layout book?

Sorry Steven, that's about all the light I can shed on the issue...
User avatar
By PivoArch
#146667
That usually happens to me when someone else is trying to send/receive their file at the same time, or when the file is in that limbo period after the send/receive but before you can see the sign in window. Usually just waiting and trying again resolves the issues.
User avatar
By Steven Dumont
#146668
Using same versions of ArchiCAD, same patches, etc.

"And is anyone updating drawings in a linked layout book?"

I'm not sure what you mean here... we have drawings in this set that are linked to other drawings (demolition plans that are linked to a demolition file). Is this what you mean?
User avatar
By Steven Dumont
#146669
PivoArch wrote:That usually happens to me when someone else is trying to send/receive their file at the same time, or when the file is in that limbo period after the send/receive but before you can see the sign in window. Usually just waiting and trying again resolves the issues.
Not the issue here...
User avatar
By PivoArch
#146671
I seem to recall that we had an issue similar to this on AC10 a few years ago, but I am pretty sure it was related to some machines being 64bit and others being 32bit, Graphisoft provided us with a new inputoutput.dll file that resolved the issue. The only other issue would be if someone is updating a hotlink of the file while you are trying to change your workspace. Is this a problem that happens all the time with a certain file or just on a specific machine. If it is a certain file then I would try saving the plp as a pln and then resharing the project.
By dirty goat
#148142
We've been experiencing the same issue with a number of teamwork files in our office. It started happening again today on a relatively new project file. Both team-members have identical hardware, and as far as I know, the same settings.

It tends to happen more readily if waiting longer between hitting the 'Send and Receive' button. Occasionally the process leads to a message that says, 'Input File is Incorrect or Memory Full - I/O Error'. Then if you click 'Okay' then choose 'Ignore Error and Continue', the file crashes and reopens. Once the other team member sends and receives, the changes in the draft are able to be incorporated into the main file again.

Yes to it being a major distraction.
User avatar
By subatomic
#148165
steps that have always help me are "Receive Changes and Settings..."
If that doesn't help have someone log on with exclusive access, someone on a machine not affected by the problem, send changes and then log out.
If it persists create a new Teamwork file.
User avatar
By Steven Dumont
#148169
dirty goat wrote:We've been experiencing the same issue with a number of teamwork files in our office. It started happening again today on a relatively new project file. Both team-members have identical hardware, and as far as I know, the same settings.

It tends to happen more readily if waiting longer between hitting the 'Send and Receive' button. Occasionally the process leads to a message that says, 'Input File is Incorrect or Memory Full - I/O Error'. Then if you click 'Okay' then choose 'Ignore Error and Continue', the file crashes and reopens. Once the other team member sends and receives, the changes in the draft are able to be incorporated into the main file again.

Yes to it being a major distraction.
This is exactly what is happening here in our office. The machines we are using are exactly the same. And yes, I have tried saving it as a solo, then re-sharing, the saving it as a solo again, and re-sharing again, even changing the name of the file whilst doing it, nothing fixing the problem.

We wondered if it was an issue with the Mac's and the "Sharing and Permission" parts of the file. If someone created the file, they need to make sure everyone in the office had permission to read & write the file. We changed these settings throughout the office and that did nothing either.
User avatar
By kevin b
#148190
Not that any of the following helps you in the short run but...

We have been having the problem as well. For some time we thought it was a conflict with some teammates being on Intel and some on Power PCs (all Mac office). However we just ran into it again with a brand new teamwork file, two users (including me) with identical hardware and software. It seems to have started after the team leader (User A) went quite some time between S/R with User B S/R several times. Then it appears the event which triggered it was User B changing Workspace, after which User A could not S/R (got Can't Find Teamwork error) until User B did another S/R.

We tested again, User B change workspace, User A cant S/R until after User B completes an S/R.

Then tested User B change workspace, and immediately S/R again after changing. User A still can't S/R. It appears that only after a failed attempt at S/R by User A, does the S/R of User B temporarily "fix" the issue.

This is the first chance we have had to test some of these different scenarios, hopefully the more info we can get to Graphisoft the better. In each case the change in workspace was User B adding a layout page User A had previously been signed into.