The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Sharing a project for a team, accessing projects remotely. Setup of BIMcloud/Users/Roles, Working/Messaging in Teamwork (Example: What are the firewall settings for the BIMcloud to make it accessible over the Internet?)

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy, Marton Kiss, Istvan Moharos

User avatar
By fuzzytnth3
We use an Office Standard Library called AMA Elements AC13.lcf today I modified a Library object within an extracted version of this Library then created a new LCF file and uploaded it to our Server (a Mac Xserve running X Server 10.5.6) I then used BIM Library Manager and refreshed to update the Library.

When I tried joining a Project I got an error saying "Server Error unable to load Library" (or something like that) and it gave me the option to "Retry or Cancel" after a couple of tries I canceled and quit ArchiCAD 13. I then deleted the TW data from my local Library/Application Support folder and tried opening the Project again. This time the library loaded and everything was looking fine until I tried to edit an object within my AMA Elements AC13.lcf library to discover that all the objects in it were now Read Only.

When I checked my extracted version the permissions were set only for me to read/write while "staff" and "everyone" had permissions of "none". So I used Server Admin app to correct the permissions and made a new lcf file based on that but again no go despite the permissions of the new lcf file being read/write for all users.

Anyone know how I can fix or get round this thanks in advance
User avatar
By fuzzytnth3
I have a temporary solution and that was to load the Extracted version of the Library (with the corrected permissions).

First I had to reserve the messed up lcf Library and remove it from the Project by using the manage BIM Server Libraries... command. Then I had to Upload the extracted Library to the BIM Server

Next I had to reload the Library in the Project you have to click on one of those sneaky tucked away Graphisoft buttons/commands


To get it to add the Library to the Project. But really I would like to keep this Office Library as an lcf as it stops anyone from editing objects without my knowledge and or control.
User avatar
By Rob

a bit off the topic I apologise...
your signature shows AC13 with a wrong build number (13.003 is a version of the file format).

GS has actually moved info about versions into Help/License Information... it should show a build number something like 3000+