The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Sharing a project for a team, accessing projects remotely. Setup of BIMcloud/Users/Roles, Working/Messaging in Teamwork (Example: What are the firewall settings for the BIMcloud to make it accessible over the Internet?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy, Istvan Moharos, Marton Kiss

By Paolo Dellapiana
#158666
Hello,
about this new technologie the first problem for me is:
BIM Server doesn't start.
Mac Xserve Intel-quad 2,66 Ghz
MAC OS X 10.6.2 server

Uninstalled and reinstalled.
Changed service ports.
Changed multiple IP.

NO WAY.

Any suggestion?
Thank a lot

paolo
www.archicura.it
User avatar
By Ferenc
#158737
I have the same problem with a brand new and cute Mac Server Mini which ships with Snow Leopard Server Software.

Image

First, the management port conflicts with something,...

Image

so it needed to be changed...

Image

The problem is that the BIM server stops on it in about 10 seconds...

Image

after showing it running if stimulated by the Start Server button...

Image

as a consequence after logging in the status goes offline...

Image

after 9 sec of being stimulated with the 'Check Connection' command...

Image

If one is fast enough one can hit the send and receive in that slice of time, but if the BIM server libraries not cached on the computer they are marked as unavailable.

It's a brand new server and the client had great expectations about the BIMServer (in a small office), it's hard to explain why the great concept doesn't work.
User avatar
By Ferenc
#158738
addendum:

if I join from another computer as another user, the BIMServer Libraries
should be downloaded and cached locally, but they don't seem to be available:

Image

even though they can be reserved and what not...

Image

This might be some other problem?
User avatar
By Millard Brooking
#158847
I never could get the BIM Server to run on our server as well. I ended up setting up a separate machine to run the BIM server. I made it a headless machine that I can control by screen sharing.
User avatar
By gkmethy
#158852
Ferenc,

We have seen the server stopping problem in cases where:
- mail server name includes "_" character
- An account name in the BIM Server preferences includes a "%" character
- There is a DNS (Domain Name Server) name resolving error in the Network
- There is no DNS in your in your Mac Network, and there is no IP address-Name resolving configured in the 'Host' file of your Mac BIM Server.

In a small network your router may serve as the DNS Server, in which case make sure that your BIM Server machine is assigned a static IP Address within your office network and the corresponding name is defined in the DNS.

We have seen cases when the same computer was used as a Mac at times, and as a Windows machine at other times, which resulted that to the same Mac Address (the network card identifier) there was two different IP addresses and two different names registered in the DNS. That can cause the start/stop problem.

The library problem can very easily be also DNS related: Two clients connect to the BIM Server in two different ways (through different IP address, for example) E.g. one client in the office accesses the BIM Server via an internal IP address, and an other remote user via an external IP address. In this case one of them will not see the libraries. To avoid this, make sure that al the clients (whether local or remote) refer to the BIM Server via the same name, and that the name is correctly resolved by the DNS
User avatar
By Ferenc
#158863
the IP address is static, and it was...

However there is an update, after updating from server sw 10.6 to 10.6.2 and start over, restart the clients, etc., the server ran yesterday alll day, and the clients seem to stay online.

So it is almost running...
The library problem still remains, in the teamwork project missing objects everywhere, and the libraries marked 'Unavailable'

Image

Interesting that in the Manage BIMServer libraries dialog the libraries seem to be available, moreover, the selected libraries could be Extracted without any problem.

Hacking the host file might be the way to go, I did it on my iMac, but didn't do that on the others (sudo nano etc/hosts ... and it reminded me that you got to have a non-empty used password with admin rights), so I will check that out, although it is weird that the server can be found via the fixed IP address, the server could only serve those libraries if the hostname is set in the hosts file....

Image

The router DNS table is outside of my responsibility at this client, and every change in the router requires negotiaton and asking favor- I guess that should be common pattern for the BIMServer administrators.

I will post an update after hacking the etc/hosts file...
User avatar
By Ferenc
#158865
Update:

it worked:
sudo nano /etc/hosts
added the mac mini server entry (192.168.3.5<tab>wamini)
and now it works.

next step: set up a dell laptop and test, and test from the outside world (via dyndns)

Still interesting that although server address as dotted IP woks, the dns entry has to be there...

Thank George!
User avatar
By Ferenc
#158866
I meant to say :

Thank you, Gergely! :wink:
User avatar
By Karl Ottenstein
#158867
Hi Ferenc,

As you've seen, the hosts file acts as a mini DNS.

The server can be accessed by any number of names and addresses - local IP, public IP, public DNS names (any number of them), local DNS names (any number of them) ... all resolve to the same server. So, the Server Manager will see all that is on the server with any of those methods. But the PROJECT stores the exact name or address used to load the libraries into Library Manager ... and it is that name or address that ALL joined team members must use in order to see the libraries.

If only one team member joins via one of the other names or addresses, he/she will see the libraries as missing. If that member then deletes the libraries, and then browses to the serve and adds them all back, they will look good on his/her machine. But, the minute he/she sends/receives, the libraries will appear to be broken for all other users.

What we really need - and I'm sure Graphisoft is polishing all of these things - is a mechanism so that when someone attempts to join a project, if they browsed to the server under a different name/address than is used by the loaded libraries for the project being joined, that they are prevented from joining...and are instead automatically redirected to the proper name/address that will result in correctly loaded libraries.

Regards,
Karl
User avatar
By Ferenc
#158869
I can live with the rule that DNS has to be resolved even if the server can be found via the dotted IP address.

Ideally IF the BIMserver libraries are accessible and downloadable from a client, the Library caching should NOT fail. When somebody is using the uploaded BIMserver libraries from that on the BIMServer's responsibility should be serving the libraries for the local cache. That would be more elegant than working with two access methods.

But I think -once it's been noted- it is no problem (unless there is a crossplatform consequence).