The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Sharing a project for a team, accessing projects remotely. Setup of BIMcloud/Users/Roles, Working/Messaging in Teamwork (Example: What are the firewall settings for the BIMcloud to make it accessible over the Internet?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy, Istvan Moharos, Marton Kiss

I have a large project with a teamwork file and several pln files. To manage the drawings i created a separate PLN file just for the drawings, where i have linked the views from the various files.
Today when i wanted to update the views of the Teamwork file, i get this error message: "Unsent changes in your source project are preventing the status checking process.
Go to the project and send your changes to the Server, then press the Check Status command again in the current project."

I did Send and Receive a lot of times, but to no avail, i cannot update my views. Even if i delete them and re-link them i get a blank drawing.

What can i do???
Have you tried updating the drawings using the drawing manager?
Yes. No chance there either. I get the "?" "Needs Cheking" or the "!" "Not Read Yet" messages.

From the Navigator i see the teamwork file listed as "Running" whereas the regular PLNs are listed as "Linked" whats the difference?

Even if i delete the missing views and re-link new ones from the Teamwork file i get blank drawings and the same error message. Seems something is stuck somewhere.

This is extremely annoying
Somewhat drastic, but try
-forward merge merging in a blank AC13 template file
-if that doesn't work, save out a pln and then reshare. Test in the pla that you can fix the linking problem first before resharing.

Perhaps someone else here has another suggestion.
I haven't been working with TW2, so I don't know if this is helpful. We had a similar situation with drawings linked to a TW file -- they wouldn't update. In a separate instance of AC, we signed into TW View Only. With both files open, the drawings updated -- my guess is it just couldn't access the PLP. Now, It's all very different now, but I thought it wouldn't hurt to mention.
So, new day, new problem... (you cant get bored with Archicad...)
The views are updating now miraculously... BUT... all the doors and windows and other objects are missing.
The BIM server libraries appear not to be loading on the PLN with the views, and there is no way of linking them... when i go to "Manage BIM server libraries" i get a blank window...

But why do i have to have the libraries loaded to the PLN with only the views?
I am wondering if this could be some kind of a BIM Server name/address resolution issue.
BIM Server Libraries are usually not found for that reason.
And these hotlinkes also have a path which can get messed up in such a situation.
I think all parties involved (BIM Server, AC clients) should have the same way of identifying the BIM Server). So if it is a name (like "Office BIM Server"), then that should be used in both the server and all AC instances.
If it is identified by an IP address, then that should be used by all.
This is a bit of guessing by me because I have not encountered such situation myself.
Check out this article about the possible reasons of missing Library Parts in teamwork:

As to your original issue, I would think that the warning you get only notifies you about the status of the drawings being reliably displayed, but it should not prevent you from actually updating the drawings. So, after updating the drawings still should get them to the most current state, even though they are still marked as outdated after it. One possible way to fix it is that all the users who are signed in the source project send changes and "leave" the project. If everybody leaves the project, there should not really be any unsent changes. If there still are, then it' s a problem that only a re-share would fix. Save a PLN out of the project, and re-share it.