The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Everything related to BIMx and BIMx PRO: functionality, platforms, features, etc.

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

Hi folks,

Today I've been trying to use BIMx to show a client around a project on an iPhone. The app opened fine and I accessed & zoomed around the 3D model with no issues, however whenever I try to access the Cardboard VR option the app crashes.

I've tried several different phones and several different projects, including the Demo project, but have been having the same issue.

Has anyone else experienced this, as we never have before!!

I just tried on an old iPhone with IOS 10.3.4.
Opened demo model in BIMx Pro with Cardboard VR and had no problems.
I can't run BIMx Lab on that phone.

What BIMx app are you using (standard, Pro, Lab) and what IOS version do you have?

Maybe someone else with the same setup could test it.

Cheers Barry

BIMx standard version 2020.1.2574
iPhone 6s 13.3.1
iPhone 7 13.3

Crashes every time on both

We've just tried it on an android P20 and it worked OK, and I've just downloaded BIMx Lab onto the iPhone 6s which also works fine.
FYI - feedback from Graphisoft:

"This issue is related to the latest iOS update. Starting from iOS 13.3.1 the Cardboard VR feature is not available anymore in the BIMx and BIMx PRO apps because of some functions that became deprecated in this iOS version. We are already working hard on a partial solution and the app will not crash in the upcoming update. We will release this update as soon as possible to avoid the crashes."
Thanks for letting us know.

Good job my old phone can't upgrade to IOS 13.3.1
Not that I use the Cardboard VR very often.

I have the same problem on my iPhone XR.

For me the solution was to switch to the BimX Lab app. BimX Lab works well.