The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Everything related to BIMx and BIMx PRO: functionality, platforms, features, etc.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy

By greg_lupo
#317131
I tried to make bimxx file and put my deleveloper_id to this file but bimx app keep saying that devID is missing so extension is installed but not active.
On developer site my status is active.
is developer_id for bimx different from api developer_id?

Thanks
Greg
By greg_lupo
#317435
I asked BIMx support and They gave me an answer. I write it here back to help anyone with similar problem.

When One will playaround with API BIMx and configuring own json file, please mind not to copy json example provided on GS webpage directly to a file but rather rewrite it. In case of coping wrong whitespace symbols are pasted and they cause all the problem.
By rszabo
#318289
Hi Greg,

As we discussed, BIMx didn't install the extension properly due to the unsupported Unicode characters. With your help, it turned out that the Pages app formatted the text of BIMx API documentation.docx.

Usually, applications give notification before formatting the content of the file. The previously mentioned document opens in e.g. Word without unwanted changes, so it's not necessary to rewrite the sample extensions from scratch. Those can be copied to dedicated developer apps or even TextEdit.

If any BIMx API related questions encountering in the future, please discuss it on http://archicadapi.graphisoft.com. Our developers are monitoring that portal and provide assistance if needed.

Thanks for your collaboration.

Kind regards,
Roland