The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Topics related to the Grasshopper-ARCHICAD Connection and the various tasks that can be achieved with it.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

#294155
I've known from past experience working with pipes in grasshopper and sending them to Archicad via the grasshopper connection that Archicad files increase tremendously in size when I do this (that's a lot of surfaces). I just upgraded to Archicad 22 - and I wasn't surprised when my Archicad pln file size shot up from 80MB to over 300 MB when I sent grasshopper pipe components to Archicad via the Archicad grasshopper connection. To try to reduce the file size though, I deleted the sent components in Archicad - noticed that filesize didn't change though. I checked the embedded libraries - nothing huge. I was still getting fairly good response time from Archicad so I proceeded to carefully reduce the number and size of the pipe components in grasshopper and resent them, thinking that if somehow the sent pipe components were still in Archicad somewhere, even if they had been deleted (deleting the layer they were in after manual deletion didn't complain about any possible elements) that resending updated elements might replace whatever was still in Archicad. This time though the file size increased from 300 MB to over 700 MB! Everything became excruciatingly and tormentingly slow, even just moving people objects a couple of meters, in either ground floor view or 3D view. Ended up missing my deadline extension due to this.

After recuperating a bit with some sleep, I did further testing today. I deleted the updated pipe elements in Archicad manually (used find and select to find all the objects in the layer they were assigned to, unlocked them, and deleted them). Even after deleting these pipe elements, the slowness persisted, even just when switching from 3d window to ground floor view ( a habit I’ve acquired when saving the project file since the default choice to save is always as pln when in ground floor view – when in other views the default choice to save is the last used format, which can trip one up), and when I was finally able to get a response from the menu system so I could save the file, get this, for over 20 minutes Archicad took over 80% of CPU processing, doing Omnescient-Being knows what, so I finally killed the process – nothing was saved. I don’t know if this is related to the problem I described in my post in “Other topics” where purple line of programming code started showing up in my ground floor display window. Restarted the 723 MB pln file, which took forever, redeleted the pipe elements, this time I saved from the 3d window. This time I see the file saved in only a few seconds, which was encouraging, and this time file size was reduced to 438 mb - so I see that this time deleting the updated pipes reduced file size by 300 MB. But then when I try to return to Archicad to delete other elements and see how file size continues to be affected, I can’t, Archicad is chugging on 90% + of CPU power for at least another ten minutes (what is it doing?), so I have to kill the process again. Restart the new 438 MB pln file, imagine seeing a slight improvement in response time, but when gets stuck again at 99% plus CPU usage to just find and select layer elements with closed breps (extruded planar surfaces sent from grasshopper) I want to delete this time to see how it affects file size, I know I’m stuck again in Archicad no-man’s land. I kill the process, after waiting five minutes, restart the saved 438 mb file (each time I restart I do NOT recover the auto-saved project). This time as soon as I’m able to do anything in Archicad, all I do is delete the layer the closed breps are in, ignore the warning about elements being deleted if I delete the layer since this is exactly what I want to do, and save the file from the 3D window (which I started up in). Lo and behold I get stuck at 85% + CPU usage Archicad no man’s land again. I was annoyed earlier but this time I’m livid. So much friggin time wasted! Not being calm enough to even think about how else I can efficiently delete layers and elements layers, save possibly manually selecting each one, unlocking, selecting again and deleting, which would take longer than forever, I let Archicad chug on at 85%+ percent – maybe eventually it will finish doing what it needs to do. It goes on for half an hour. Yes, really. After half an hour I’m calmer so I kill the process. New workaround is to restarting the 438 mb file and before deleting the closed breps, resave it as Archicad 21 format and try deleting the closed breps from Grasshopper there and then reopening the Archicad 21 format file with Archicad 22. But no go. Stuck in 85%+ CPU usage Archicad no man’s land again when I try resaving the 438 mb file opened with Archicad 22 in Archicad 21 format. After five minutes I kill the process instead of waiting longer. Not sure what my options are at this point. Start over in Archicad 21?

Btw each time I kill the Archicad process the bug report window comes up but it soon crashes itself before I can do anything with it wibukey.sys not installed message. Least of my problems at the moment.
Needless to say, all these problems, glitches, and even the testing and problem-reporting, take time from other valuable projects.

I can send any relevant Archicad/grasshopper information/files that might help to understand and solve these problems - if I ever get a response here from a Graphisoft person. This kind of performance is excruciating. I've used Archicad for many years but these kind of problems make me seriously think about switching to Revit, even though I’d have to start from scratch to learn it.
#294157
Update:

I remembered that I had a 1100 mb pln file saved as Archicad 21 back when I still had the pipe and closed brep elements in Archicad 22 (see my post on code lines showing up in ground floor window in Archicad 22).

viewtopic.php?f=13&t=66166

This 1100 mb pln file opened up in ground floor view in Archicad 21. I just immediately delete the layers with the pipes and closed breps. This time I’m able to save it – Archicad 21 format of course. File size gets reduced to 519 mb. I proceed to systematically delete the elements I’ve been creating and working with. No surprises really, file size gets reduced bit by bit as I would generally expect.

But then here’s the thing. When I’ve deleted everything that I’ve created and worked with, then proceeded to delete everything left in the embedded library, and even deleted all my worksheets (for the worksheets file size change was insignificant), I am still left with an Archicad 21 project file that is 443 mb. In the 3d window I turn on all the remaining layers (the standard Archicad layers that one starts with in a new project file), see nothing, I choose fit in window, see nothing, I select all with ctrl-A see nothing, I draw a selection box over the whole window with the arrow tool see nothing.

In the ground floor I do all these things as well but still see nothing.
What on earth is going on? Where is this remaining huge 443 file size coming from? What other diagnostic tools can I use to find the file size culprit?
Summary: when I saved a 723 mb file Archicad file with all I had been working with, including pipes and closed breps sent from Grasshopper, as Archicad 21 file size became 1100 mb. After starting up this file in Archicad 21 and deleting the pipes and closed breps, file size got reduced to 519 mb. When I deleted everything else I had been working with, including everything in the embedded library and even all the worksheets, file size is still 488.

Help!
#294224
You should contact your local reseller with the issue, possibly providing them with the problematic files. They can then forward it to GRAPHISOFT, if needed.
This is the usual way of handling technical support issues.
#294587
Hi,

Well, I see you mention several different issues here. I think we can sort this out though. First of all I would like to ask you for some files so that I could do some tests, and then ask you a few questions breaking this thing down into smaller portions.

So, could you please send me the following (I can send you an upload link in a Private message if you need): But let's look at your issues one-by-one:
  1. The file size: ARCHICAD's file structure is pretty complicated, so if you start adding things to a project, it might grow larger not just based on the size of the content, but also markers/flags/codes sorting this content. This can mean that if you take a template file that is 1 MB, add a lot of stuff to it so it would be 20 MB, and then delete everything so that it only contains things from the template, it might still remain 5 MB. This is actually something that we are trying to control more-and-more from each version to another, but for now this is what we have.
    Additionally, if you delete things, it might still leave the previous elements' place in the code empty (so the file will still be as big as before, but the content would be empty). I think originally this was made like this for faster read-write back in the day of really slow hard drives (but I am just guessing). Anyhow, the point is that if you want to reduce the project's size, it might be good to open the project, save as compressed PLN/PLA, re-open, and save it a few more times. This should eliminate some of this.
  2. The code snippet on the floor plan: Based on the picture you posted, it looks like a default ARCHICAD text box (they have this font, size and color). I am not sure what made it appear, but maybe if grasshopper fails it produces this as a "backup" or maybe there's a label there that works different in ARCHICAD 22 than it does in ARCHICAD 21. I can also imagine that this is a behaviour only happening on Windows 7, because that is not a supported/tested Windows version (even Microsoft stopped supporting it in 2015). ARCHICAD should work on it, but there's no guarantee, it might be worth upgrading.
    Anyways, I will know more when I take a look at the project.
  3. Grasshopper Pipes make ARCHICAD heavy: Both ARCHICAD and Grasshopper have their own kinks, and it helps to be familiar with the limitations of both to make the workflows as smooth as possible. I have not seen your project yet (so I am not even sure what you are modeling with GH), but based on the picture from the other topic it looks like you brought everything through from Grasshopper as ARCHICAD Morphs. Morphs are the heaviest elements in ARCHICAD, so if you have a lot of them, that can really put its toll on speed/resources. Also, while Rhino/GH mainly works with nurbs curves (which they can define efficiently with math), ARCHICAD can only handle flat polygons and straight edges in 3D. So these curves are segmented into straight parts, and that can mean a huuuge amount of polygons.
    To lighten this up, you have several options (but best combined):
    • You can use the 'ARCHICAD Object' component in Grasshopper instead of the 'Morph' component. Objects have less control points, so even with the same amount of polygons, the don't make the project as slow as Morphs would.
    • You can convert the pipes (the breps) to rhino meshes before transferring to archicad. Rhino Meshes basically have the same geometry that ARCHICAD uses (that I described above) so if you convert the shapes to meshes before transferring them, you can control the degree of the segmentation (thus creating less polygons when you transfer the geometry to ARCHICAD).
    • Pipes are really hard to define with basic ARCHICAD tools, but I think if you take a complex profile beam in ARCHICAD, and send it through the same path as you did with the pipe (only a bit more segmented) then you might get a similar result in ARCHICAD which is way less heavy. If something can be modeled in ARCHICAD with a simpler shape/tool, try to use that when transferring (makes for a smaller size and faster 3D).
So, these are my initial thoughts. Feel free to add any info you think might be relevant and definitely correct me if I assumed something wrong!
I am looking forward to getting your files, so that I can take a look at it myself! I am sure we can greatly improve the speed and the size!

Regards,