The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Topics related to the Grasshopper-ARCHICAD Connection and the various tasks that can be achieved with it.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

By Rupert
#295140
I am using the latest version of ArchiCAD 22 and Rhino 6

The live connection was working well.

I installed an update for Rhino - Release 2019-2-27

I had some issues so I uninstalled Rhino and reinstalled the older version of Rhino 6.

Rhino now crashes as soon as I turn on the live connection.

I tried uninstalling and reinstalling the live connection and latest hotfix for ArchiCAD
I tried removing all add-on's

I still have the same issue
#295748
Hello,
  • Does it still crash if you have an empty ARCHICAD file and an empty GH definition when you start the connection?
  • Can you also try this in Rhino 5 maybe?
  • Do you have any other Add-ons installed for Rhino/Grasshopper? It is a very common issue that other add-ons have a conflict with the connection tool and can cause a crash.
  • Maybe the installation/uninstallation wasn't complete, and while you have a new version of the add-on on the ARCHICAD side, you may have an older version on the Rhino side? Please uninstall the add-on, and then go and remove any traces that might be left manually. The GH Add-on should be in the following folder:
    <user folder>\Application Data\Grasshopper\Libraries
Let me know about your results!

Regards,
#295972
Hi dkovacs
Thanks for the reply !
So,
* Rhino crashes whenb i start the connection event with an empty file in both rhino and ArchiCAD,
* This happens on rhino 5.13, and rhino 6 on multiple subversions, 6.08, 6.12 etc...
* Yes i have some addons on grasshopper, like panneling tools, weavebird, lunchbox..
* i installed and uninstalled the connection ( clean uninstall) several times, nothing new
#295994
I recently have the same problem, but only with AC22.

I tried it with my old AC 21, and it's working fine.

Clean reinstall, deleting grasshopper components folder, removing grasshopper add-ons didn't help either.

It used to be working fine on previous AC22 live connection,
#296027
Hello,
GH-AC is crashing with me also, not all the time but very often indeed.
Here's the answer I've got after sending the bug reporting from Rhino:
"Thank you for the crash report. This is an automated response to the crash report you recently sent.

Rhino crashed because of an error in your ArchiCAD plugin. Please contact Graphisoft for an updated plugin to fix the crash."

Thanks!