The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Topics related to the Grasshopper-ARCHICAD Connection and the various tasks that can be achieved with it.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

By Rupert
#295140
I am using the latest version of ArchiCAD 22 and Rhino 6

The live connection was working well.

I installed an update for Rhino - Release 2019-2-27

I had some issues so I uninstalled Rhino and reinstalled the older version of Rhino 6.

Rhino now crashes as soon as I turn on the live connection.

I tried uninstalling and reinstalling the live connection and latest hotfix for ArchiCAD
I tried removing all add-on's

I still have the same issue
#295748
Hello,
  • Does it still crash if you have an empty ARCHICAD file and an empty GH definition when you start the connection?
  • Can you also try this in Rhino 5 maybe?
  • Do you have any other Add-ons installed for Rhino/Grasshopper? It is a very common issue that other add-ons have a conflict with the connection tool and can cause a crash.
  • Maybe the installation/uninstallation wasn't complete, and while you have a new version of the add-on on the ARCHICAD side, you may have an older version on the Rhino side? Please uninstall the add-on, and then go and remove any traces that might be left manually. The GH Add-on should be in the following folder:
    <user folder>\Application Data\Grasshopper\Libraries
Let me know about your results!

Regards,
#295972
Hi dkovacs
Thanks for the reply !
So,
* Rhino crashes whenb i start the connection event with an empty file in both rhino and ArchiCAD,
* This happens on rhino 5.13, and rhino 6 on multiple subversions, 6.08, 6.12 etc...
* Yes i have some addons on grasshopper, like panneling tools, weavebird, lunchbox..
* i installed and uninstalled the connection ( clean uninstall) several times, nothing new
#295994
I recently have the same problem, but only with AC22.

I tried it with my old AC 21, and it's working fine.

Clean reinstall, deleting grasshopper components folder, removing grasshopper add-ons didn't help either.

It used to be working fine on previous AC22 live connection,
#296027
Hello,
GH-AC is crashing with me also, not all the time but very often indeed.
Here's the answer I've got after sending the bug reporting from Rhino:
"Thank you for the crash report. This is an automated response to the crash report you recently sent.

Rhino crashed because of an error in your ArchiCAD plugin. Please contact Graphisoft for an updated plugin to fix the crash."

Thanks!
#299732
Frank Gergaud wrote:
Tue Apr 09, 2019 8:51 am
Hi,

I'm also experiencing similar problem. Except that it's ArchiCAD 22 that crash not Rhino. Did you figure out where the problem was from?

Best,

Frank
Hello Frank,

I replied to bouhmidage in this thread: viewtopic.php?f=43&t=66277

But I don't think it is the same issue, if it crashes ARCHICAD, not Rhino. Could you sort the problem out?

If not, can you send me a bug ID of one of these crashes, so that I can check it in our system? Also, when does the crash happen for you? When you click "Start Connection"?

Regards,
#300983
Hi Daniel,

Thanks for your answer,

I didn't figure out a way to fix the problem but I know why it comes. The problem happens when I reopen an ArchiCAD model that was previously linked to a Grasshopper script. The live connection seems confused if one of the geometry does not exist anymore in ArchiCAD. That's probably why Rhino-Grasshopper or ArchiCAD crashes. I've been sending the bug report to Rhino and they told me that the problem was from the plugin (ArchiCAD live coonection) and they can't do much about it unfortunately. So to avoid as much as possible this issue, I bake the geometry from Grasshopper to Rhino and work from there. If there is update, I have to clean all the geometry from ArchiCAD into Grasshopper and re select the elements I need. It's not the best workflow so I hope that it could fix.

Don't hesitate to contact me if you need more information to reproduce the bug.

Here is one is one bug ID that I've sent to ArchiCAD. The problem happen when I start the live connection between the ArchiCAD model and a Grasshopper script already linked before:

AC22-2019-08-23-14-11-30-3166

Frank
#301200
Hi Frank,

Thanks for the Bug ID. We looked at it, but unfortunately it is not an issue that we are familiar with, so we need some further investigation to find out what could cause this. Could you check the following for me?
  • Is it only happening on your computer, or if you try on someone else's with the same file, it also crashes?
  • If it only happens on your computer, please check my suggestions in this other thread, because those are the usual issues that come up.
  • If it also happens on other computers, it might be a geometry or information specific to your project. In that case, it would be great if you could send me the GH and PLA files, so that I can try it myself.
  • The new update for the connection tool should come out in the next few weeks (GH-AC 6021). If you are reading after that time, try it with the update to see if that helps.
  • If ARCHICAD is the one crashing most of the times, please also send me several more Bug IDs (each might contain some different information about the issue).
  • If Rhino is the one that crash mostly, you should be able to gather the crash report from the desktop that could tell us more about the problem.
I hope we will be able to sort it out. Thanks in Advance!

Regards,