The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Topics related to the Grasshopper-ARCHICAD Connection and the various tasks that can be achieved with it.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

#300088
Hi guys,

I have a big problem with using the Life Connection. When trying to establish the connection i get the following message in Archicad "Grasshopper not running" when in fact it is.
Capture.PNG
Capture.PNG (14.27 KiB) Viewed 1723 times
I am currently using Archicad 22 Built 6001 INT FULL and Rhino 5 SR 14. The Grasshopper built is 0.9.0076.
#300373
Hi,

This can be because of a lot of things. The first thing you should do, is check in Grasshopper, whether you can see the ARCHICAD tab with the ARCHICAD components. If you see it, that means that both sides of the connection tool are installed, but they cannot see each other. If you can't see it, that means that the Add-on has been properly installed for ARCHICAD, but not for Grasshopper. In this case you will need to uninstall the connection tool, and reinstall it again. Make sure that you are using the same user account to do the installation, because while the ARCHICAD Add-on is installed for ARCHICAD with every user, the Grasshopper Add-ons are only installed fro the current user (so if your Administrator installed it, it will not work).

If that was fine, you can see the ARCHICAD tab and ARCHICAD also shows, then make sure you place at least one component in Grasshopper. AC will only see that GH is running if there is an open project in it (which means at least one component is placed).

If that is not the case then there is probably a connection issue between AC and GH. This can be caused by any 3rd party application, so make sure you close every other application (even the anti-virus), before making the connection.

The connection can also get disturbed, if the Add-on has different versions in AC and GH. To make sure that is not the case, after you installed the Add-on, please also run the ARCHICAD 6001 update, so that it can update everything.

Let me know if this was helpful.

Regards,
#309592
Hi! I am having the same problem here! I fresh installed the latest version of ArchiCAD for Mac (I have an educational license, I don't know if that's an issue) and the latest version of Rhino 6 for Mac which runs the latest version of Grasshopper (1.0.0007) with no other plug-ins installed. I installed the latest version of the Grasshopper connection plug-in and reinstalled ArchiCAD latest version upon the already installed one. No cigar. I keep getting the message <grasshopper not running>. I need some help here! Thank you
#309923
Edoardo B. wrote:
Sun Apr 12, 2020 3:18 pm
Hi! I am having the same problem here! I fresh installed the latest version of ArchiCAD for Mac (I have an educational license, I don't know if that's an issue) and the latest version of Rhino 6 for Mac which runs the latest version of Grasshopper (1.0.0007) with no other plug-ins installed. I installed the latest version of the Grasshopper connection plug-in and reinstalled ArchiCAD latest version upon the already installed one. No cigar. I keep getting the message <grasshopper not running>. I need some help here! Thank you
Hi,

Thank you for sharing the issue and I am sorry about the experience!

I'm wondering if you are using macOS 10.15 (Catalina). If the answer is yes, then this is a known issue for us. It looks like the add-on is having difficulty in establishing the connection between ARCHICAD 23 and Rhino 6 on macOS 10.15. Currently, it looks like Rhino 5 does not have such an issue when connecting to ARCHICAD 23 on macOS 10.15, so I can only suggest it as a workaround at the moment!

I hope we'll be able to find a solution to this issue soon! Once again, I am very sorry for the inconvenience!
Thank you for your understanding!

Best regards,
Minh
#311075
Hi! Thank you for answering.
No, I'm not using Catalina. I still have Mojave v. 10.14.6.
I'm using the plug-in with Rhino 5, but it crashes all the times making it basically useless.
I've also installed the newest version of Grasshopper-ARCHICAD-Connection 23-INT-4006-1.0 hoping it would fix the issue, but it doesn't.
Please help! Thank you!
#311100
Edoardo B. wrote:
Tue May 19, 2020 7:37 pm
Hi! Thank you for answering.
No, I'm not using Catalina. I still have Mojave v. 10.14.6.
I'm using the plug-in with Rhino 5, but it crashes all the times making it basically useless.
I've also installed the newest version of Grasshopper-ARCHICAD-Connection 23-INT-4006-1.0 hoping it would fix the issue, but it doesn't.
Please help! Thank you!
Hi,

Thank you for your question! Please follow this thread to see my answer here.

Best regards,
Minh