The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Installation and download/setup issues; upgrading, operating system compatibility; getting started/training guides/tutorials. (Example: I cannot launch Archicad, please help!)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy

User avatar
By dhnguyen
When I'm in the office, I am able to run ArchiCAD normally on my PC.
Recently I tried Remote Desktop Connection from home into my work PC and I'm getting this "Library Load Error" Message. It says, "LoadLibrary failed with error 87: The parameter is incorrect."

I did some search online and people who got the same error message said that it's best to disable the video card specified by remote desktop connection. I had my IT department looking into this and we're not able to solve this problem.
So I uninstalled ArchiCAD and re-installed it and I'm still getting the same error message, except that this time I'm getting a Microsoft C++ runtime error message too....
Has anybody has this problem and how did you solve it?
Please see attached for the 2 error messages.
Error Message.JPG
Error Message.JPG (94.39 KiB) Viewed 178 times
Microsoft C++.PNG
Microsoft C++.PNG (45.21 KiB) Viewed 178 times
User avatar
By Barry Kelly
I don't have a solution for you.
But just to be clear, you are using Remote Desktop Connection to connect into your work PC and you are running Archicad on the work PC and the license is on the work PC?
You are not trying to run Archicad on your home PC using the license from the work PC?

Also does Archicad still actually run, just not loading the library?
I am wondering if it is not actually referring to the Graphisoft Archicad library, but some program resource.

User avatar
By Lingwisyer
Are you using Windows Remote Desktop Protocol? If so, don't... RDP does not support OpenGL beyond 1.0... So my guess is that it is also preventing some other protocol from initialising...

User avatar
By dhnguyen
I usually dont remote desktop into my work PC in order to use ArchiCAD. I'm currently using a company-issued laptop and it doesn't have ArchiCAD installed. So that's why I use the Remote Desktop Connection It's only temporary...

ArchiCAD runs just fine when I use the computer in the office. The problem is it doesn't open at all when I try to remote connect into it. It gives me that error message about the LibraryLoad Error. It only works if there's already a session running. But I'm not there physically to open ArchiCAD to keep it running.
User avatar
By Lingwisyer
If it works fine when an instance is already running, I would say that it is your remote desktoping program. Can you try a different one?

User avatar
By dhnguyen
I can only use the Windows Remote Desktop Connection to get to my work PC.