The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Everything about using Libraries and Library Parts - Doors/Windows/Objects/Stairs etc. (Example: How can I display a Transom above my Door?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy, Gergely Feher

By lukaso
#322564
When I save 2D Objects with autotext elements I can Create my own labels. Great.

If I save 2D Objects with other labels as labels it works too!!! this is what i need. But it only works AC23 not in 24!?
Why not?

(In 23. it puts a "call" into the GDL)
Attachments
Bildschirmfoto 2021-02-18 um 11.23.16.jpg
Bildschirmfoto 2021-02-18 um 11.23.16.jpg (318.77 KiB) Viewed 288 times
User avatar
By mnguyen
#322782
Hello,

Thank you very much for the report and I am very sorry about the issue!

I was unable to reproduce the issue. Could you share with me a small PLA file containing the setup you used to create the label in Archicad 24 for further investigation?

Looking forward to hearing from you!

Best regards,
Minh
User avatar
By mnguyen
#322801
Hello Lukas,

Thank you very much for the file!

I saw that the label you're trying to save as a new custom label is "Classification and Properties Label" (or the equivalent in GER version). This label works by pulling out properties of the attached element (in this case, the wall). If you save this label again as a custom label (regardless of whether it comes with another 2D element or not), the function of the label will be lost, therefore it cannot display anything.

When I tested with Archicad 23, the same thing happens, so I don't know whether it works in any previous versions or not. Could you confirm whether the same workflow creates a usable label in previous versions?

Best regards,
Minh
User avatar
By runxel
#322812
Having access to file I understand the task at hand. Was slightly misunderstanding it first.

So yeah, it doesn't work in Archicad 24, but indeed, it does work in Archicad 23. Even stranger: just not with all labels tho, making it kinda erratic.
User avatar
By mnguyen
#322835
Hi Lukas,

Thank you very much for the file!

Unfortunately, I was still unable to create a working label using the given file on AC23 GER and INT, running different builds (5010 and 6004). I will ask my colleagues for more info about this. As soon as I have an answer I will let you know!

Best regards,
Minh
User avatar
By mnguyen
#322848
Hi Lukas,

I asked the help of my colleagues to see why the label creation worked for you but not for me. It turned out that this function worked on Archicad 23 GER, but it never worked on INT version. In Archicad 24 GER, this function also did not work. Let me ask the developers to see why it behaved like this. As soon as I have an answer I will let you know!

Best regards,
Minh